*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_endpoint (1m)              
Title
Content
Arch
Section
 

Contents


 endpoint(1m)             Open Software Foundation              endpoint(1m)




 NAME    [Toc]    [Back]
      endpoint - A dcecp object that manages endpoint information in local
      RPC endpoint maps

 SYNOPSIS    [Toc]    [Back]
      endpoint create -interface interface_id -binding string_binding_list
      [-object object_uuid_list] [-annotation annotation] [-noreplace]

      endpoint delete -interface interface_id -binding string_binding_list
      [-object object_uuid_list]

      endpoint help [operation | -verbose]

      endpoint operations

      endpoint show [host_address] [-uuid |
      -interface interface_id [-version version] [-object object_uuid_list]]


 ARGUMENTS    [Toc]    [Back]
      host_address
                An RPC string binding that describes a host's location.  The
                binding information contains an RPC protocol and the host's
                network address.  Any specific host's network address can be
                obtained by using the getip command.

      operation The name of the endpoint operation for which to display help
                information.


 DESCRIPTION    [Toc]    [Back]
      The endpoint object operates on remote procedure call (RPC) endpoint
      mappings on the local host.  Endpoints contain an interface identifier
      and one or more string bindings; optionally, they contain object
      Universal Unique Identifiers (UUIDs) and an annotation.

      Endpoint mappings are stored in the endpoint map maintained by the DCE
      daemon (dced) for DCE Version 1.1 hosts.  DCE Version 1.0 uses the RPC
      daemon (rpcd) to maintain the endpoint map.  The server object has
      some operations (for example, disable and enable) that affect
      endpoints maintained by dced. However, server object operations do not
      operate on endpoints maintained by DCE Version 1.0 hosts.  The
      endpoint object affects all endpoint maps on the local host, whether
      maintained by rpcd or dced.

      Since endpoints have no names, the argument to these operations is not
      the name of an endpoint.  Earlier versions of rpcd allowed remote
      access to endpoints, but this was a security problem.  Only the
      endpoint show command allows access to endpoint maps on remote
      systems.  The server object allows some remote operations on dced
      endpoint maps, which are free of the security problem, depending on



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      how dced is configured.

      Use the various endpoint operations to create, delete, and show RPC
      endpoint information in local host endpoint maps.

 DATA STRUCTURES    [Toc]    [Back]
      interface_id
                The interface identifier of an RPC interface.  The interface
                identifier takes the following form:

                interface-uuid,major-version.minor-version

                The version numbers are optional, but if you omit a version
                number, the value defaults to 0. The UUID is a hexadecimal
                string and the complete version number is a decimal string.
                For example:

                -interface ec1eeb60-5943-11c9-a309-08002b102989,3.11

                Leading zeros in version numbers are ignored.

                Alternatively, you can use Tcl syntax in the following form:

                {interface-UUID major-version.minor-version}

                For example:

                -interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0}



      string_binding_list
                An RPC string binding that describes a server's location.
                The value has the form of an RPC string binding, without an
                object UUID.  The binding information contains an RPC
                protocol, a network address, and (sometimes) an endpoint
                within [] (square brackets) as follows:

                rpc-prot-seq:network-addr[endpoint]

                For a well-known endpoint, include the endpoint in the
                string binding surrounded by brackets.  You may need to use
                the \ (backslash) to escape the brackets as shown in the
                following example.  Without the backslash, dcecp interprets
                the brackets as enclosing another command.

                -binding ncadg_ip_udp:63.0.2.17\[5347\]


                For a dynamic endpoint, omit the endpoint from the string
                binding.  For example:



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




                -binding ncacn_ip_tcp:16.20.15.25


                Alternatively, you can use Tcl syntax.  For example:

                -binding {ncacn_ip_tcp 130.105.1.227 1072}


      object_uuid
                The UUID of an object.  The UUID is a hexadecimal string.
                For example:

                -object 3c6b8f60-5945-11c9-a236-08002b102989


                Alternatively, you can use Tcl syntax.  For example:

                -object {3c6b8f60-5945-11c9-a236-08002b102989}


      annotation
                An informational text string that helps you to identify the
                purpose of the endpoint.  Use single or double quotation
                marks around the annotation field of endpoints to include
                internal spaces in an annotation, for example:

                -annotation "Bulletin Board Server, Version 1.3a"


                Alternatively, you can use Tcl syntax.  For example:

                -annotation {Bulletin Board Server, Version 1.3a}


      version   Specifies which interface version numbers to be returned
                with a show operation.  Specify versions by using one of the
                following values for the -version option:


                all       The interface version is ignored.

                exact     Both the major and minor versions must match the
                          specified versions.

                compatible
                          The major version must match the specified
                          version, and the minor version must be greater
                          than or equal to the specified version.

                major_only
                          The major version must match the specified



 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




                          version; the minor version is ignored.

                upto      The major version must be less than or equal to
                          that specified. If the major versions are equal,
                          the minor version must be less than or equal to
                          that specified.


                If the -version option is absent, the command shows
                compatible version numbers.


 OPERATIONS    [Toc]    [Back]
    endpoint create
      Creates new endpoints in the local endpoint map database.  The syntax
      is as follows:

      endpoint create -interface interface_id -binding string_binding_list
      [-object object_uuid_list] [-annotation annotation] [-noreplace]


      Options    [Toc]    [Back]

      -interface interface_id
                This required option declares the interface identifier of a
                single RPC interface.

                See DATA STRUCTURES for the format of an interface
                identifier.

      -binding string_binding_list
                This required option declares a list of one or more RPC
                string bindings.

                See DATA STRUCTURES for the format of a string binding.

      -object object_uuid_list
                Declares the UUID of an object.  Each create operation
                accepts a list of up to 32 object UUIDs.

                See DATA STRUCTURES for the format of an object UUID.

      -annotation annotation
                Defines an annotation string for the endpoint.  The
                annotation string enables you to identify the purpose of the
                endpoint.  The annotation can be any textual information,
                for example, an interface name associated with the interface
                identifier or a description of a service or resource
                associated with a group.

                Use quotation marks around the annotation field of endpoints



 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




                to include internal spaces in an annotation, or use Tcl
                syntax.

      -noreplace
                Use the -noreplace option when you want a host to run
                multiple instances of a server.  Normally, when you add an
                interface-binding combination (a mapping) that already
                exists in an endpoint map, dcecp replaces the existing
                mapping with the new one.  This behavior limits the number
                of server instances to one.  Bypass this limitation by using
                the -noreplace option.  Using this option can cause obsolete
                endpoints to accumulate in the endpoint map.  Remove
                obsolete endpoints by using the endpoint delete command.


      The create operation creates new endpoints in the endpoint map
      database on the local host.  This command takes no arguments.  It
      requires the -interface and -binding options, and accepts the -object
      and -annotation options.  The value of the -binding and -object
      options can be a list, but the others must be a single value.  If the
      mapping already exists, it is replaced unless the -noreplace option is
      included.

      This command creates a cross product from the -interface, -binding,
      and -object options and adds each element in the cross product as a
      separate registration in the local endpoint map. If you supply no
      object UUIDs, the corresponding elements in the cross product contain
      a nil object UUID.  For example, suppose that you have an interface
      (if1), three bindings (b1, b2, and b3), and four object UUIDs (o1, o2,
      o3, and o4).  The resulting 12 elements in the cross product are as
      follows:

      {if1,b1,o1}  {if1,b1,o2}  {if1,b1,o3}  {if1,b1,o4}
      {if1,b2,o1}  {if1,b2,o2}  {if1,b2,o3}  {if1,b2,o4}
      {if1,b3,o1}  {if1,b3,o2}  {if1,b3,o3}  {if1,b3,o4}


      An annotation string is part of each of these 12 elements, but is not
      shown for clarity.

      This operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the endpoint create command.

      Examples    [Toc]    [Back]

      The following command adds an endpoint to the local host's endpoint
      map.  This example uses the \ (backslash) twice to escape the
      brackets.  Without the two backslash characters, dcecp interprets the



 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      brackets as enclosing another command.

      dcecp> endpoint create -interface 458ffcbe-98c1-11cd-bd93-0000c08adf56,1.0 \
      > -binding ncacn_ip_tcp:130.105.1.227\[1067\]
      dcecp>


      The following example uses Tcl syntax to create an endpoint in the
      local host's endpoint map.

      dcecp> endpoint create -interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0} \
      > -binding {ncacn_ip_tcp 130.105.1.227 1072} \
      > -object {76030c42-98d5-11cd-88bc-0000c08adf56} \
      > -annotation {Bulletin Board Server, Version 1.3a}
      dcecp>


    endpoint delete
      Deletes the specified endpoints from the local endpoint map database.
      The syntax is as follows:

      endpoint delete -interface interface_id -binding string_binding_list
      [-object object_uuid_list]


      Options    [Toc]    [Back]

      -interface interface_id
                This required option declares the interface identifier of a
                single RPC interface.

                See DATA STRUCTURES for the format of an interface
                identifier.

      -binding string_binding_list
                This required option declares a list of one or more string
                bindings.

                See DATA STRUCTURES for the format of a string binding.

      -object object_uuid_list
                Declares the UUID of an object.  Each delete operation
                accepts a list of up to 32 object UUIDs.  The UUID is a
                hexadecimal string.

                See DATA STRUCTURES for the format of an object UUID.


      The delete operation deletes the specified endpoints from the endpoint
      map database.  This command takes no arguments.  It requires the -
      interface and -binding options, and also accepts the -object option.



 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      The values of all but the -interface option may be lists.  If the
      mappings do not exist, an error is generated.

      This command creates a cross product from the -interface, -binding,
      and -object options and removes each element in the cross product from
      the local endpoint map.  See the endpoint create command above for
      more details.

      This operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the endpoint delete command.

      Examples    [Toc]    [Back]

      The following command removes an endpoint object from the local host's
      endpoint map.  This example uses the \ (backslash) twice to escape the
      brackets.  Without the two backslash characters, dcecp interprets the
      brackets as enclosing another command.

      dcecp> endpoint delete  -interface 458ffcbe-98c1-11cd-bd93-0000c08adf56,1.0 \
      > -binding ncacn_ip_tcp:130.105.1.227\[1072\]
      dcecp>


      The following example uses Tcl syntax to delete an endpoint from the
      local host's endpoint map.

      dcecp> endpoint delete -interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0} \
      > -binding {ncacn_ip_tcp 130.105.1.227 1072}
      dcecp>


    endpoint help
      Returns help information about the endpoint object and its operations.
      The syntax is as follows:

      endpoint help [operation | -verbose]


      Options    [Toc]    [Back]

      -verbose  Displays information about the endpoint object.


      Used without an argument or option, the endpoint help command returns
      brief information about each endpoint operation. The optional
      operation argument is the name of an operation about which you want
      detailed information. Alternatively, you can use the -verbose option
      for more detailed information about the endpoint object itself.



 Hewlett-Packard Company            - 7 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the endpoint help command.

      Examples    [Toc]    [Back]

      dcecp> endpoint help
      create              Creates RPC endpoints for the specified interface.
      delete              Deletes a set of RPC endpoints.
      show                Returns the RPC endpoints for a specified interface.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    endpoint operations
      Returns a list of the operations supported by the endpoint object. The
      syntax is as follows:

      endpoint operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the endpoint operations
      command.

      Examples    [Toc]    [Back]

      dcecp> endpoint operations
      create delete show help operations
      dcecp>


    endpoint show
      Returns a list of information about endpoints for the local host or a
      remote host.  The syntax is as follows:

      endpoint show [host_address] [-uuid |
       -interface interface_id [-version version] [-object
      object_uuid_list]]


      Options    [Toc]    [Back]

      -uuid     Specifies that the UUID of the endpoint map is to be
                returned. It cannot be used with any other option.




 Hewlett-Packard Company            - 8 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      -interface interface_id
                This option specifies the interface identifier of a single
                RPC interface for which you want to see the endpoint mapping
                information.

                See DATA STRUCTURES for the format of an interface
                identifier.

      -version version
                Specifies interface version numbers to be returned with the
                show operation.

                See DATA STRUCTURES for the exact behavior and format of
                version values.

      -object object_uuid_list
                Declares the UUID of an object.  Each show operation accepts
                a list of up to 32 object UUIDs.

                See DATA STRUCTURES for the format of an object UUID.


      The show operation returns a list of information about endpoints in
      the endpoint map of a local or remote host. With no options, it
      returns all the local endpoint mappings. The -interface, -version, and
      -object options can be used so that only those endpoint mappings
      matching the supplied values are returned.  The -object option accepts
      a list as a value; the others do not. The optional host_address
      argument is the address of the remote host whose endpoint map is to be
      shown. If no argument is supplied, the local host's endpoint map is
      used.

      If the -uuid option is specified, then the UUID of the specified
      host's endpoint map is to be returned, rather than any information
      about the endpoints themselves.  Each endpoint map is given a UUID on
      creation.  If you know the current UUID of an endpoint map, you can
      delete any other stale UUIDs that may be in the RPC entry.  If you
      specify the -uuid option, you may not specify any other options.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the endpoint show command.

      Examples    [Toc]    [Back]

      The following example uses Tcl syntax to specify an interface for
      which to return local endpoint map information:

      dcecp> endpoint show -interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0}
      {{object 76030c42-98d5-11cd-88bc-0000c08adf56}
      {interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0}}



 Hewlett-Packard Company            - 9 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 endpoint(1m)             Open Software Foundation              endpoint(1m)




      {binding {ncacn_ip_tcp 130.105.1.227 1072}}
      {annotation {Bulletin Board Server, Version 1.3a}}}
      dcecp>


      The following command returns the endpoint objects in the local
      endpoint map that contain the specified interface identifier.  This
      interface supports two object UUIDs on two protocol sequences:

      dcecp> endpoint show -interface 257df1c9-c6d3-11ca-8554-08002b1c8f1f,1.0
      {{object a57104f4-dfd0-11ca-b428-08002b1c8a62}
      {interface {257df1c9-c6d3-11ca-8554-08002b1c8f1f 1.0}}
      {binding {ncacn_ip_tcp 130.105.1.227 1040}}
      {annotation {cdsd [910]}}}

      {{object a57104f4-dfd0-11ca-b428-08002b1c8a62}
      {interface {257df1c9-c6d3-11ca-8554-08002b1c8f1f 1.0}}
      {binding {ncadg_ip_udp 130.105.1.227 1163}}
      {annotation {cdsd [910]}}}

      {{object b32648c6-928d-11cd-b4b5-0000c08adf56}
      {interface {257df1c9-c6d3-11ca-8554-08002b1c8f1f 1.0}}
      {binding {ncacn_ip_tcp 130.105.1.227 1042}}
      {annotation cds_clerkserver}}

      {{object b32648c6-928d-11cd-b4b5-0000c08adf56}
      {interface {257df1c9-c6d3-11ca-8554-08002b1c8f1f 1.0}}
      {binding {ncadg_ip_udp 130.105.1.227 1168}}
      {annotation cds_clerkserver}}
      dcecp>


      The following command returns the UUID of the endpoint map on the host
      with the specified network address:

      dcecp> endpoint show ncadg_ip_udp:130.105.1.227 -uuid
      7273c754-e51c-11cd-bc0e-0000c08de054
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_rpcentry(1m), dcecp_rpcgroup(1m),
      dcecp_rpcprofile(1m), dcecp_server(1m).


 Hewlett-Packard Company           - 10 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_clock HP-UX A dcecp object that manages the clock on a local or remote host
rpccp_add_mapping HP-UX Adds or replaces server address information in the local endpoint map
dcecp_xattrschema HP-UX A dcecp object that manages schema information for ERAs
dcecp_host HP-UX A dcecp task object that manages host information in a DCE cell
dcecp_hostdata HP-UX A dcecp object that manages a DCE host's cell affiliation information
rpccp_remove_mapping HP-UX Removes specified elements from the local endpoint map
rpccp_show_mapping HP-UX Shows the elements of the either the local or a remote endpoint map
t6get_endpt_mask IRIX get or set endpoint security attribute mask, get or set endpoint default security attributes
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service