host(1m) Open Software Foundation host(1m)
NAME [Toc] [Back]
host - A dcecp task object that manages host information in a DCE cell
SYNOPSIS [Toc] [Back]
host catalog [cell_name] [-simplename]
host configure host_name
-cell cellname
-secmaster master_security_server_name
-cds cds_server_name
-password password
{-client | -server}
[-remote]
[-addlan additional_lan_name]
[-dts {global | local | clerk | none}]
[-timeserver time_server]
[-lowuid low_uid]
[-lowgid low_gid]
[-keyseed keyseed]
[-riphost rip_hostname]
[-tolsec tol_sec]
[-nosync]
[-protseq config_protseq]
[-admin admin_principal]
host help [operation | -verbose]
host operations
host ping host_name
host show [host_name]
host start [host_name]
host stop [host_name] [-force]
host unconfigure [host_name] [-force] [-remmaster]
ARGUMENTS [Toc] [Back]
cell_name The name of a single cell to operate on. The name must be a
fully qualified cell name such as either of the following:
/.../gumby1.com
/.:
host_name The name of a single host to operate on. Some host commands
accept a fully qualified name (as in
Hewlett-Packard Company - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
/.../cellname/hosts/hostname), while others accepts a cell
relative name (as in hosts/hostname) or a simple name (as in
hostname). See the individual command descriptions in
OPERATIONS for details.
operation The name of the host operation for which to display help
information.
DESCRIPTION [Toc] [Back]
The host task object represents DCE processes running on a machine in
(or to be added to) a DCE cell. The host task object allows
administrators to configure and start DCE on machines easily.
The host task object can configure and start the core DCE services on
a server or a client machine. The services include the DCE daemon
(dced), the Cell Directory Service (CDS) daemons (cdsd and cdsadv),
the Distributed Time Service (DTS) daemon (dtsd), the security service
daemon (secd), and the audit daemon (auditd). The argument to this
command is the DCE name of a host to operate on. If an argument is
omitted, the command operates on the local host, if possible. The
behavior of commands operating locally may differ from the behavior of
commands operating remotely, with more operations performed on the
local host than may be possible remotely. See OPERATIONS for details.
OPERATIONS [Toc] [Back]
host catalog
Returns a list of names of hosts in the cell. The syntax is as
follows:
host catalog [cell_name] [-simplename]
The catalog operation returns a list of names of hosts in the cell.
By default, the names are fully qualified. Use the -simplename option
to return cell-relative names. The optional cell_name argument
specifies a cell to operate in, and should be entered as a fully
qualified cell name (either /.: or /.../cell_name).
Privileges Required [Toc] [Back]
You must have r (read) permission to the /.:/hosts directory in CDS.
Examples [Toc] [Back]
The following example lists the full names of all the DCE hosts that
have entries in the CDS /.:/hosts directory in the local cell:
dcecp> host catalog
/.../my_cell.goodco.com/hosts/alpha
/.../my_cell.goodco.com/hosts/beta
Hewlett-Packard Company - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
/.../my_cell.goodco.com/hosts/gamma
dcecp>
The following example lists the simple names of all the DCE hosts that
have entries in the CDS /.:/hosts directory in the specified cell:
dcecp> host catalog /.../gumby1 -simplename
hosts/blech
hosts/jacobi
hosts/oddball
dcecp>
host configure
Configures a single machine named by the argument as a DCE server or
as a client into an existing DCE cell. The syntax is as follows:
host configure host_name
-cell cellname
-secmaster master_security_server_name
-cds cds_server_name
-password password
{-client | -server}
[-remote]
[-addlan additional_lan_name]
[-dts {global | local | clerk | none}]
[-timeserver time_server]
[-lowuid low_uid]
[-lowgid low_gid]
[-keyseed keyseed]
[-riphost rip_hostname]
[-tolsec tol_sec]
[-nosync]
[-protseq config_protseq]
[-admin admin_principal]
Options [Toc] [Back]
-cell cellname
Specifies the name of the cell in which the host is to be
configured. The format is /.../cellname or simply cellname.
-client Configures the host as a DCE client machine. The machine
will be configured to run dced (including the secval
service), a DTS clerk (dtsd), cdsadv, and auditd.
-server Configures the host as a DCE server machine. The machine
will be configured to run dced (including the secval
service), a security server (secd), a CDS server (cdsd and
Hewlett-Packard Company - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
cdsadv), a DTS server (dtsd) and auditd.
-secmaster master_security_server_name
Specifies the hostname of the security master server in the
form hostname.
-cds cds_server_name
Specifies the hostname of the CDS server in the form
hostname.
-password password
Specifies the password of the cell administrator.
-admin admin_principal
Optionally specifies the principal name of the cell
administrator. It defaults to cell_admin.
-remote Configures dced with remote administration (-r) turned on.
If not selected, remote administration is off.
-addlan additional_lan_name
Configures an additional lan name on the local server. If
not selected, the default is NULL.
-dts {global | local | clerk | none}
Configure the DTS service as either global, local, clerk or
none. The default is none.
-timeserver time_server
The hostname of the time server with which to synchronize
clocks, specified in the form hostname. The default is the
host specified in the -secmaster option,
master_security_server_name.
-lowuid low_uid
The starting point for new UIDs being created. The default
is to automatically calculate the starting point.
-lowgid low_gid
The starting point for new GIDs being created. The default
is to automatically calculate the starting point.
-keyseed keyseed
The keyseed to use for the initial security master.
-riphost rip_hostname
A relocatable IP hostname for hosts with Service Guard
installed. The default is NULL if no Service Guard is
installed.
Hewlett-Packard Company - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
-tolsec tol_sec
The clock tolerance in seconds. The default is 120.
-nosync Do not synchronize clocks with a server machine upon
configuration of a client host. The default is to
synchronize clocks.
-protseq config_protseq
Set the configuration protocol. The default is
ncacn_ip_tcp.
The configure operation configures the local machine named by the
host_name argument as a server or as a client into an existing DCE
cell. In the client case, the cell must already exist and must have
security and naming services operating. When configuring a server,
the host should not be part of an existing cell. In all cases, DCE
software must be installed on the target machine. The host_name
argument is the name of the local host machine without the cell name
prepended, as in the following:
hosts/hostname
hostname
This operation returns an empty string on success.
Privileges Required [Toc] [Back]
You must have root authority.
Examples [Toc] [Back]
The following example configures the machine hydra in the cell
/.../my_cell.com as a client:
dcecp> host configure hosts/hydra -client \
> -cell my_cell.com -password fstzkl -secmaster scylla \
> -cds serpent
dcecp>
The following example configures the machine mstr_node as both the
master security server and initial CDS server in the new cell gumby1.
dcecp> host configure mstr_node -server -cell gumby1 \
> -cds mstr_node -secmaster mstr_node -password -dce- \
> -dts global -remote
dcecp>
Hewlett-Packard Company - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
host help
Returns help information about the host task object and its
operations. The syntax is as follows:
host help [operation | -verbose]
Options [Toc] [Back]
-verbose Displays information about the host task object.
Used without an argument or option, the host help command returns
brief information about each host operation. The optional operation
argument is the name of an operation about which you want detailed
information. Alternatively, you can use the -verbose option for more
detailed information about the host task object itself.
Privileges Required [Toc] [Back]
No special privileges are needed to use the host help command.
Examples [Toc] [Back]
dcecp> host help
catalog Returns a list of configured hosts in the cell.
configure Configures a host into the cell as a client or server.
ping Determines if DCE is responding on the specified host.
show Returns all DCE processes configured on the specified host.
start Starts DCE on the specified host.
stop Stops DCE on the specified host.
unconfigure Removes the host from the name and security databases.
help Prints a summary of command-line options.
operations Returns a list of the valid operations for this command.
dcecp>
host operations
Returns a list of the operations supported by the host task object.
The syntax is as follows:
host operations
The list of available operations is in alphabetical order except for
help and operations, which are listed last.
Privileges Required [Toc] [Back]
Hewlett-Packard Company - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
No special privileges are needed to use the host operations command.
Examples [Toc] [Back]
cecp> host operations
catalog configure ping show start stop unconfigure help operations
dcecp>
host ping
Tests whether DCE processes are accessible from the network. The
syntax is as follows:
host ping host_name
The ping operation tests whether DCE processes are accessible from the
network. It contacts the endpoint mapper (either rpcd or dced,
whichever listens on port 135) on the specified host. The host_name
argument is the fully qualified name of the host to ping, as in the
following:
/.:/hosts/hostname
The operation returns 1 if the host responds, 0 if it does not.
Privileges Required [Toc] [Back]
No special privileges are needed to use the host ping command.
Examples [Toc] [Back]
The following example pings host hydra:
dcecp> host ping /.:/hosts/hydra
1
dcecp>
host show
Returns a list describing all processes that are configured to run on
the specified host. The syntax is as follows:
host show [host_name]
The show operation returns a list describing all processes that are
configured to run on the specified host. The optional host_name
argument is the cell-relative or simple name of the local DCE host,
such as hosts/hostname or hostname. If not specified, the local host
is used. The information returned includes the status of DCE
Hewlett-Packard Company - 7 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
processes either running or configured on the specified host. The
value running is used to represent a DCE process that is configured
and running. The value notrunning is used to represent a DCE process
that is configured but not running. The value notconfigured is used
to represent a DCE process that is not configured.
The host show command uses the /etc/rc.config.d/dce file to determine
which DCE processes are configured on the host.
Privileges Required [Toc] [Back]
No special privileges are needed to use the host show command.
Examples [Toc] [Back]
dcecp> host show hosts/oddball
{dced running}
{secval running}
{auditd notconfigured}
{secd running}
{cdsadv running}
{cdsd running}
{gdad notconfigured}
{dtsd notrunning}
{dts_null_provider notconfigured}
{dts_ntp_provider notconfigured}
{dts_spectracom_provider notconfigured}
{pwd_strengthd notconfigured}
dcecp>
host start
Starts all DCE processes on the specified host. The syntax is as
follows:
host start [host_name]
The start operation starts all DCE processes on the specified host.
This command uses the /sbin/init.d/dce file to determine which DCE
processes to start.
The host_name argument is the cell-relative or simple name of the
local host, as in the following:
hosts/hostname
hostname
Hewlett-Packard Company - 8 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
This operation returns an empty string on success.
Privileges Required [Toc] [Back]
You must have root authority.
Examples [Toc] [Back]
The following example starts all configured DCE processes on host
hydra:
dcecp> host start hosts/hydra
dcecp>
host stop
Stops all DCE processes on the specified host. The syntax is as
follows:
host stop [host_name] [-force]
Options [Toc] [Back]
-force Specifies that any servers that fail to stop normally should
be stopped using a stricter stopping mechanism.
The stop operation stops all DCE processes on the specified host.
This command uses the /sbin/init.d/dce file to determine which DCE
processes to stop.
The host_name argument is the cell-relative or simple name of the
local host, as in the following:
hosts/hostname
hostname
This operation returns an empty string on success.
Privileges Required [Toc] [Back]
You must have root authority.
Examples [Toc] [Back]
The following example stops the running DCE processes on host hydra:
dcecp> host stop hosts/hydra
Hewlett-Packard Company - 9 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
dcecp>
host unconfigure
Unconfigures the local host from a cell. The syntax is as follows:
host unconfigure [host_name] [-force] [-remmaster]
Options [Toc] [Back]
-force Specifies that any errors that occur during an unconfigure
operation are to be ignored and the unconfigure operation
should continue.
-remmaster
Must be used if the node being unconfigured is a security
server.
The unconfigure operation unconfigures the local host from a cell. To
unconfigure a node, the operation deletes the following:
+ All objects, directories and links from /.:/hosts/hostname
including the directory itself.
+ All principal names beginning with hosts/hostname.
The unconfigure operation takes the cell relative or simple name of
the local host to unconfigure, as in the following:
hosts/hostname
hostname
This operation returns an empty string on success.
Privileges Required [Toc] [Back]
You must have the appropriate permission to delete CDS objects and
directories. You must also have the appropriate permission to delete
principals from the registry. Refer to the appropriate reference page
on each object for more details.
Examples [Toc] [Back]
The following example unconfigures host hydra from the cell:
dcecp> host unconfigure hosts/hydra
Hewlett-Packard Company - 10 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
host(1m) Open Software Foundation host(1m)
dcecp>
RELATED INFORMATION [Toc] [Back]
Commands: dcecp(1m), dcecp_account(1m), dcecp_aud(1m),
dcecp_directory(1m), dcecp_dts(1m), dcecp_principal(1m),
dcecp_registry(1m).
Hewlett-Packard Company - 11 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96 [ Back ] |