*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_rpcgroup (1m)              
Title
Content
Arch
Section
 

Contents


 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




 NAME    [Toc]    [Back]
      rpcgroup - A dcecp object that manages an RPC group entry in CDS

 SYNOPSIS    [Toc]    [Back]
      rpcgroup add rpcgroup_name_list -member member_name_list

      rpcgroup create rpcgroup_name_list

      rpcgroup delete rpcgroup_name_list

      rpcgroup help [operation | -verbose]

      rpcgroup import rpcgroup_name_list -interface interface_id
      [-object object_uuid]  [-max integer] [-noupdate]

      rpcgroup list rpcgroup_name_list [-member member_name_list]
      [-noupdate]

      rpcgroup operations

      rpcgroup remove rpcgroup_name_list -member member_name_list


 ARGUMENTS    [Toc]    [Back]
      operation The name of the rpcgroup operation for which to display help
                information.

      rpcgroup_name_list
                Specifies a list of one or more names of the RPC groups to
                be operated on.


 DESCRIPTION    [Toc]    [Back]
      The rpcgroup object represents a remote procedure call (RPC) group
      entry in the Cell Directory Service (CDS). Each RPC group is named in
      the DCE namespace; therefore, each operation takes as an argument a
      list of names of group entries to manipulate. An RPC group is a
      container that contains only the names of RPC server entries or the
      names of other RPC groups; it contains no other data.

 DATA STRUCTURES    [Toc]    [Back]
      interface_id
                The interface identifier of an RPC interface.  The interface
                identifier takes the following form:

                interface-uuid,major-version.minor-version

                The version numbers are optional. If you omit a version
                number, the default is 0. The UUID is a hexadecimal string
                and the complete version number is a decimal string. For
                example:



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




                -interface ec1eeb60-5943-11c9-a309-08002b102989,3.11

                Leading zeros in version numbers are ignored.

                Alternatively, you can use Tcl syntax.  For example:

                -interface {458ffcbe-98c1-11cd-bd93-0000c08adf56 1.0}


      object_uuid
                The UUID of an object.  The UUID is a hexadecimal string,
                for example:

                -object 3c6b8f60-5945-11c9-a236-08002b102989


                Alternatively, you can use Tcl syntax.  For example:

                -object {3c6b8f60-5945-11c9-a236-08002b102989}


 OPERATIONS    [Toc]    [Back]
    rpcgroup add
      Adds a member to the specified group entry in CDS. The syntax is as
      follows:

      rpcgroup add rpcgroup_name_list -member member_name_list


      Options    [Toc]    [Back]

      -member member_name_list
                This required option declares the name of a member to be
                added to the specified group entry.  The member_name_list
                argument is a list of names of one or more members to be
                added to all of the specified groups.  (The names need not
                exist when they are added.)  All members are added to all
                groups.


      The add operation adds a member to the specified group entry in CDS.
      The required rpcgroup_name_list argument is a list of one or more full
      CDS names of the groups to which you want to add members.  This
      operation returns an empty string on success.  If member_name_list
      contains the names of duplicate or existing members, the duplicates
      are ignored and no errors are generated.

      Privileges Required    [Toc]    [Back]

      You need i (insert) permission to the parent directory. You also need
      both r (read) permission and w (write) permission to the CDS object



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      entry (the target group entry).

      Examples    [Toc]    [Back]

      The following command adds the member /.:/LandS/anthro/Cal_host_3 to
      the group /.:/LandS/anthro/Calendar_group:

      dcecp> rpcgroup add /.:/LandS/anthro/Calendar_group \
       -member /.:/LandS/anthro/Cal_host_3
      dcecp>


    rpcgroup create
      Creates an empty RPC group entry in CDS. The syntax is as follows:

      rpcgroup create rpcgroup_name_list


      The create operation creates a new (empty) RPC group entry in CDS.
      Since an empty group is the same as an empty RPC entry or RPC profile,
      calling rpcgroup create is the same as calling rpcentry create or
      rpcprofile create. The rpcgroup_name_list argument is a list of names
      of RPC groups to be created.  This operation returns an empty string
      on success.  If the RPC group already exists, an error is returned.

      Privileges Required    [Toc]    [Back]

      You need i (insert) permission to the parent directory.

      Examples    [Toc]    [Back]

      The following command creates a new group called
      /.:/LandS/anthro/Calendar_group:

      dcecp> rpcgroup create /.:/LandS/anthro/Calendar_group
      dcecp>


    rpcgroup delete
      Removes the specified group from CDS.  The syntax is as follows:

      rpcgroup delete rpcgroup_name_list


      The delete operation removes the specified group entry from CDS.  The
      rpcgroup_name_list argument is a list of names of RPC group entries to
      be deleted.  This operation returns an empty string on success. If the
      RPC group entry does not exist, an error is generated.

      Privileges Required    [Toc]    [Back]




 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      You need w (write) permission to the CDS object entry (the target
      group entry).

      Examples    [Toc]    [Back]

      The following command removes the group
      /.:/LandS/anthro/Calendar_group from CDS.

      dcecp> rpcgroup delete /.:/LandS/anthro/Calendar_group
      dcecp>


    rpcgroup help
      Returns help information about the rpcgroup object and its operations.
      The syntax is as follows:

      rpcgroup help [operation | -verbose]

      Options    [Toc]    [Back]

      -verbose  Displays information about the rpcgroup object.


      Used without an argument or option, the rpcgroup help command returns
      brief information about each rpcgroup operation. The optional
      operation argument is the name of an operation about which you want
      detailed information. Alternatively, you can use the -verbose option
      for more detailed information about the rpcgroup object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the rpcgroup help command.

      Examples    [Toc]    [Back]

      dcecp> rpcgroup help
      add                 Adds members to a list of RPC groups.
      create              Creates a list of empty RPC groups.
      delete              Deletes a list of RPC groups.
      import              Returns the bindings from a list of RPC groups.
      list                Returns the members of a list of RPC groups.
      remove              Removes members from a list of RPC groups.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    rpcgroup import
      Returns a string binding from the specified RPC group. The syntax is
      as follows:




 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      rpcgroup import rpcgroup_name_list -interface interface_id
      [-object object_uuid]  [-max integer] [-noupdate]


      Options    [Toc]    [Back]

      -interface interface_id
                Declares the interface identifier of a single RPC interface.

                See DATA STRUCTURES for the format of an interface
                identifier.

      -object object_uuid
                Declares the UUID of an object.  The UUID is a hexadecimal
                string.

                See DATA STRUCTURES for the format of an object UUID.

      -max integer
                Specifies the maximum number of string bindings to return.
                A value greater than one returns a list containing up to the
                number of bindings specified by the value.

      -noupdate Normally, name service data is cached locally on each
                machine in a cell.  If a name service inquiry can be
                satisfied by data in the local CDS cache, this cached data
                is returned.  However, locally cached copies of name service
                data might not include a recent CDS update. If the -noupdate
                option is not specified, dcecp goes to one or more CDS
                servers to retrieve the required data, updating the local
                CDS cache.  Use the -noupdate option to avoid taking the
                time to update the local cache when you have reason to
                believe that the local cache is up to date.


      The import operation returns a string binding from the specified RPC
      group.  The rpcgroup_name_list argument is a list of names of RPC
      groups to import from.  The operation uses the -interface and -object
      options to specify matching bindings. The operation also accepts the
      -max option to specify a number of string bindings to return. The
      order of bindings returned is arbitrary.

      Privileges Required    [Toc]    [Back]

      You need r (read) permission to the specified CDS object entry (the
      starting name service entry) and to any CDS object entry in the
      resulting search path.

      Examples    [Toc]    [Back]





 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      The following command imports a binding:

      cecp> rpcgroup import /.:/ortho_group \
       -interface {ec1eeb60-5943-11c9-a309-08002b102989 1.1} \
       -object 30dbeea0-fb6c-11c9-8eea-08002b0f4528
      {ncadg_ip_udp 15.22.48.25}
      {ncacn_ip_tcp 15.22.48.25}
      dcecp>


    rpcgroup list
      Returns a list of the names of all members of the specified group. The
      syntax is as follows:

      rpcgroup list rpcgroup_name_list [-member member_name_list]
      [-noupdate]


      Options    [Toc]    [Back]

      -member member_name_list
                Specifies a list of names of one or more members to be
                returned from all groups named in the rpcgroup_name_list
                argument.  Use this option to check for specific member
                names.  The member_name_list argument specifies a list of
                names of RPC entries, RPC groups, or RPC profiles; they are
                only references stored in the RPC group and do not have to
                exist outside of the group.  All members specified are
                listed from all RPC groups specified in the argument.

      -noupdate Use -noupdate to avoid taking the time to update the local
                cache.

                See rpcgroup import for more information.


      The list operation returns a list of the names of all members of the
      specified group.  The names returned are fully qualified and are
      returned in an arbitrary order.  The rpcgroup_name_list argument is a
      list of names of RPC groups whose members' names are to be returned.

      Privileges Required    [Toc]    [Back]

      You need r (read) permission to the CDS object entry (the target group
      entry).

      Examples    [Toc]    [Back]

      The following example lists all the members of the group
      /.:/subsys/applications/infobases, in the order in which they were
      added to the group:



 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      dcecp> rpcgroup list /.:/subsys/applications/infobases
      /.../my_cell.goodcompany.com/subsys/applications/video_server
      /.../my_cell.goodcompany.com/subsys/applications/bbs_server
      /.../my_cell.goodcompany.com/subsys/applications/audio_server1
      /.../my_cell.goodcompany.com/subsys/applications/audio_server2
      /.../my_cell.goodcompany.com/subsys/applications/clipart_server
      /.../my_cell.goodcompany.com/subsys/applications/photo_server1
      /.../my_cell.goodcompany.com/subsys/applications/photo_server2
      dcecp>


      The following example uses the -member option to list a specific
      member of the group /.:/subsys/applications/infobases:

      dcecp> rpcgroup list /.:/subsys/applications/infobases \
      > -member /.:/subsys/applications/bbs_server
      /.../my_cell.goodcompany.com/subsys/applications/bbs_server
      dcecp>


    rpcgroup operations
      Returns a list of the operations supported by the rpcgroup object. The
      syntax is as follows:

      rpcgroup operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the rpcgroup operations
      command.

      Examples    [Toc]    [Back]

      dcecp> rpcgroup operations
      add create delete import list remove help operations
      dcecp>


    rpcgroup remove
      Removes one or more members from the specified group. The syntax is as
      follows:

      rpcgroup remove rpcgroup_name_list -member member_name_list


      Options    [Toc]    [Back]




 Hewlett-Packard Company            - 7 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 rpcgroup(1m)             Open Software Foundation              rpcgroup(1m)




      -member member_name_list
                This required option lets you specify a list of names of one
                or more members to be removed from all groups named in the
                rpcgroup_name_list argument.  The member_name_list argument
                specifies a list of names of RPC entries, RPC groups, or RPC
                profiles; these are only references stored in the RPC group
                and need not exist outside of the group.  All members
                specified are removed from all RPC groups specified in the
                argument.


      The remove operation removes one or more members from the specified
      group.  The rpcgroup_name_list argument is a list of names of RPC
      groups from which to have members removed.  The value of the required
      -member option is a list of names of RPC entries, RPC groups, or RPC
      profiles.  If a specified member does not exist in an RPC group, an
      error is returned.  This operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      You need r (read) permission and w (write) permission to the CDS
      object entry (the target group entry).

      Examples    [Toc]    [Back]

      The following command removes the member
      /.:/subsys/applications/video_server from the RPC group
      /.:/subsys/applications/infobases:

      dcecp> rpcgroup remove /.:/subsys/applications/infobases \
      > -member /.../my_cell.goodcompany.com/subsys/applications/video_server
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands:    dcecp(1m),    dcecp_endpoint(1m),     dcecp_rpcentry(1m),
      dcecp_rpcprofile(1m).


 Hewlett-Packard Company            - 8 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_rpcprofile HP-UX A dcecp object that manages an RPC profile entry in CDS
dcecp_group HP-UX A dcecp object that manages a group in the DCE Security Service
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_dts HP-UX A dcecp object that manages a dtsd process
dcecp_server HP-UX A dcecp object that manages DCE application servers
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_link HP-UX A dcecp object that manages a soft link in CDS
dcecp_registry HP-UX A dcecp object that manages a registry in the DCE Security Service
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service