*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_clock (1m)              
Title
Content
Arch
Section
 

Contents


 clock(1m)                Open Software Foundation                 clock(1m)




 NAME    [Toc]    [Back]
      clock - A dcecp object that manages the clock on a local or remote
      host

 SYNOPSIS    [Toc]    [Back]
      clock compare [dts_entity] [-server dts_entity]

      clock help [operation | -verbose]

      clock operations

      clock set [dts_entity]
      {-to DTS_timestamp [-abruptly -epoch epoch_number | -bypass] |
      -epoch  epoch_number}

      clock show [dts_entity] [-dtsd  | -inetd | -dced]

      clock synchronize [dts_entity] [-dtsd [-abruptly] | -inetd | -dced]


 ARGUMENTS    [Toc]    [Back]
      dts_entity
                Identifies the dtsd server or clerk to act on.

                With the -server option in the compare operation, dts_entity
                can identify a DTS time provider.

                When used without the -dced or -initd options, dts_entity
                can be either of the following:


                  +  The name of a dtsd server, which can be on a remote
                     host, in the format:

                     /.../cellname/hosts/hostname/dts-entity


                  +  A string binding for the remote host on which the dtsd
                     is running, such as:

                     ncacn_ip_tcp:130.105.1.227


                     Alternatively you can specify the binding in Tcl
                     format, such as:

                     {ncacn_ip_tcp 130.105.1.227}


                When used with the -dced or -inetd options, dts_entity
                identifies the server by a simple host name in the form



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




                hostname.

      operation The name of the clock operation for which to display help
                information.


 DESCRIPTION    [Toc]    [Back]
      The clock object represents the clock on a system and the time that it
      tells.  This object has commands to display and set the time. The time
      setting functionality is provided by DTS, unless you specify either
      the -dced or -inetd option.  The optional argument to the clock
      command is the name of a DCE Version 1.1 dtsd running on some machine.
      Without an argument, the _s(dts) convenience variable is checked.  If
      this variable is not set, the command operates on the clock on the
      local machine.

      Use the -epoch option to change only the epoch number of the dtsd.

 OPERATIONS    [Toc]    [Back]
    clock compare
      Returns the difference between the clocks on the local machine and a
      DTS server in the cell.  The syntax is as follows:

      clock compare [dts_entity] [-server dts_entity]


      Options    [Toc]    [Back]

      -server dts_entity
                Optionally names a specific DTS server against which to
                compare the host clock.

                See ARGUMENTS for the format of the dts_entity argument.


      The compare operation returns the difference between the clocks on the
      local machine and a DTS server in the cell.  If a server is not
      specified, the command picks the last responding server returned by
      dts catalog.  An optional argument compares a remote host's clock
      against a DTS server.  An optional -server option compares the clock
      against a specific DTS server.

      The DTS server that responds to this operation may be communicating
      directly with an external time provider.  If so, the provider
      attribute returned by this operation will be set to yes.

      Privileges Required    [Toc]    [Back]

      You must have r (read) permission  on /.:/hosts/hostname/dts-entity to
      execute the command.




 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




      Examples    [Toc]    [Back]

      dcecp> clock compare
      {server /.:/gumby/hosts/oddball/dts_entity}
      {provider no}
      {skew -0-00:00:00.020I-----}
      dcecp>


      dcecp> clock compare -server /.:/hosts/santafe/dts-entity
      {server /.:/hosts/santafe/dts-entity}
      {provider yes}
      {skew -0-00:00:00.292I1.431}
      dcecp>


    clock help
      Returns help information about the clock object and its operations.
      The syntax is as follows:

      clock help [operation | -verbose]


      Options    [Toc]    [Back]


      -verbose  Displays information about the clock object.


      Used without an argument or option, the clock help command returns
      brief information about each clock operation. The optional operation
      argument is the name of an operation about which you want detailed
      information. Alternatively, you can use the -verbose option for more
      detailed information about the clock object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the clock help command.

      Examples    [Toc]    [Back]

      dcecp> clock help
      compare             Returns the difference between the local clock and a server.
      set                 Sets the system clock to the specified time.
      show                Returns the current time as a DTS style timestamp.
      synchronize         Synchronizes the local clock with the specified server.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>





 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




    clock operations
      Returns a list of the operations supported by the clock object. The
      syntax is as follows:

      clock operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the clock operations command.

      Examples    [Toc]    [Back]

      dcecp> clock operations
      compare set show synchronize help operations
      cecp>


    clock set
      Sets the clock to the specified time. The syntax is as follows:

      clock set [dts_entity]
      {-to DTS_timestamp [-abruptly -epoch epoch_number | -bypass] |
      -epoch epoch_number}


      Options    [Toc]    [Back]


      -to DTS_timestamp
                This option specifies a DTS timestamp as the time to which
                to set the clock.  You can specify the time in the ISOcompliant
 time format, as follows:

                CCYY-MM-DD-hh:mm:ss.fff


      -abruptly Specifies to set the clock abruptly rather than gradually
                adjust it to the computed time.

      -bypass   Sets the system clock to the specified time without using
                DTS.

      -epoch epoch_number
                Specifies an epoch_number that matches the epochs of servers
                with which the local clock synchronizes.





 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




      The set operation sets the local clock to the specified time.  An
      optional argument sets the clock on a remote host.  The -to option
      specifies a DTS timestamp as the time to which to set the clock.  If
      you do not specify the -abruptly option, DTS adjusts the clock
      gradually to the specified time.  The -abruptly option changes to the
      specified time, without gradual adjustments. If you specify the
      -abruptly option, you must also specify the -epoch option to indicate
      a new epoch. You can also use the -epoch option without specifying a
      time to pull the specified dts_entity out of synchronization. The -
      bypass option causes DTS to be ignored and sets the system clock
      directly.  This operation returns an empty string on success.

      Note that setting your system clock is a dangerous operation.  If your
      machine is not synchronized with other machines in the cell, other DCE
      services, especially CDS, do not operate correctly.  See the OSF DCE
      Administration Guide for more information about DTS.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission on the clock object
      (/.:/hosts/hostname/dts-entity) if using DTS to set the time,
      otherwise no special privileges are required.

      Examples    [Toc]    [Back]

      dcecp> clock set -to 1994-07-15-16:27:28.000-04:00 -abruptly -epoch 1
      dcecp>

      dcecp> clock set -epoch 5
      dcecp>


    clock show
      Returns a DTS-style timestamp including the time differential factor
      (TDF). The syntax is as follows:

      clock show [dts_entity] [-dtsd | -inetd | -dced]


      Options    [Toc]    [Back]


      -dced     Use dced services instead of DTS to report the time.

      -inetd    Use inetd socket connections instead of DTS to report the
                time.

      -dtsd     Use DTS services to report the time (default).






 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




      The show operation returns a DTS-style timestamp with the TDF
      indicated. Use the dts_entity argument to specify a remote host on
      which to show the clock.

      Two options let you specify that the time should be returned without
      using DTS services:


        +  The -dced option specifies that dced services should be used
           instead of DTS services

        +  The -inetd option specifies that inetd socket connections should
           be used instead of DTS


      Privileges Required    [Toc]    [Back]

      You must have r (read) permission on the clock object
      (/.:/hosts/hostname/dts-entity) if using DTS to show the time,
      otherwise no special privileges are required.

      Examples    [Toc]    [Back]

      dcecp> clock show
      1994-07-15-16:28:02.229+00:00I-----
      dcecp>

      dcecp> clock show oddball -dced
      1994-07-16-17:29:05.321+00:00I-----
      dcecp>


    clock synchronize
      Causes dtsd to synchronize with a server. The syntax is as follows:

      clock synchronize [dts_entity] [-dtsd [-abruptly] | -inetd | -dced]


      Options    [Toc]    [Back]


      -abruptly Causes the clock to be set abruptly rather than gradually
                adjusted to the computed time.

      -dced     Use dced services instead of DTS as the time source.

      -inetd    Use inetd socket connections instead of DTS as the time
                source.

      -dtsd     Use DTS services as the time source.




 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 clock(1m)                Open Software Foundation                 clock(1m)




      The synchronize operation causes the local dtsd to synchronize the
      local clock gradually with the cell time from DTS servers. The
      -abruptly option changes to the specified time immediately, without
      gradual adjustments.

      By default, the time is retrieved from DTS. If the -dced option is
      specified, the time is retrieved from dced services.  If the -inetd
      option is specified, the time is retrieved from inetd socket
      connections. The optional dts_entry argument synchronizes the clock on
      the named remote host.  This operation returns an empty string on
      success.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission on the clock object
      (/.:/hosts/hostname/dts-entity) if using DTS to synchronize the time,
      otherwise no special privileges are required.

      Examples    [Toc]    [Back]

      dcecp> clock synchronize
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_dts(1m), dcecp_utc(1m), dtsd(1m).


 Hewlett-Packard Company            - 7 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_audfilter HP-UX A dcecp object that manages the event filters on a DCE host
dcecp_aud HP-UX A dcecp object that manages the audit daemon on a DCE host
dcecp_secval HP-UX A dcecp object that manages the security validation service on a host
dcecp_host HP-UX A dcecp task object that manages host information in a DCE cell
dcecp_endpoint HP-UX A dcecp object that manages endpoint information in local RPC endpoint maps
dtsdate HP-UX Sets local clock from a remote dtsd server host
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_directory HP-UX A dcecp object that manages a CDS directory
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service