*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_cdscache (1m)              
Title
Content
Arch
Section
 

Contents


 cdscache(1m)             Open Software Foundation              cdscache(1m)




 NAME    [Toc]    [Back]
      cdscache - A dcecp object that manages a local CDS cache

 SYNOPSIS    [Toc]    [Back]
      cdscache create server_name -binding server_binding

      cdscache delete server_name

      cdscache discard [server_name]

      cdscache dump

      cdscache help [operation | -verbose]

      cdscache operations

      cdscache show server_name {-server | -clearinghouse}


 ARGUMENTS    [Toc]    [Back]
      operation The name of the cdscache operation for which to display help
                information.

      server_name
                The simple name of the cached server machine. A simple name
                is not a cell-relative name (such as /.:/hosts/pelican).
                Some examples of simple names are pelican and hosts/pelican.


 DESCRIPTION    [Toc]    [Back]
      The cdscache object represents the Cell Directory Service (CDS) cache
      on the local node.  The CDS cache contains information about servers
      and clearinghouses known to the local machine, and also contains user
      data about CDS entries that have been read.  The create and delete
      operations apply only to the server information.  The show and dump
      operations can display additional information.

 OPERATIONS    [Toc]    [Back]
    cdscache create
      Creates knowledge of a server in the local client's cache. The syntax
      is as follows:

      cdscache create server_name -binding server_binding


      Options    [Toc]    [Back]

      -binding server_binding
                The required -binding option lets you specify the binding
                information for a CDS server.  This option takes a
                server_binding argument, which is the protocol sequence and



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




                network address of the server node.  The string format is as
                follows:

                protocol-sequence:network-address

                The Tcl format is as follows:

                {protocol-sequence network-address}


                A protocol-sequence is a character string identifying the
                network protocols used to establish a relationship between a
                client and server. Protocol sequences have a specific format
                that depends on the network address that is supplied in the
                binding; for example ncacn_ip_tcp (for connection-based
                protocol) or ncadg_ip_udp (for datagram protocol) The
                network-address is a string representing the network address
                of the server node.


      The create operation creates knowledge of a server in the local
      client's cache. The server_name argument is the simple name of a
      cached server.  (An example of a simple name would be pelican, as
      opposed to a  cell-relative name like /.:/hosts/pelican.) This command
      is typically used to provide configuration information manually to a
      client that cannot configure itself automatically. Providing
      configuration information manually may be necessary, for instance, to
      provide the client with addressing information about a server across a
      WAN.  Once the client knows about one server, it can find other
      servers through referrals. This operation returns an empty string on
      success.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission to the client system,
      /.:/hosts/hostname/cds-clerk.

      Examples    [Toc]    [Back]

      The following command creates knowledge of the server pelican in the
      local client's cache:

      dcecp> cdscache create pelican -binding ncacn_ip_tcp:16.20.15.25
      dcecp>


    cdscache delete
      Removes knowledge of a server that you had specifically created from
      the local client's cache.  The syntax is as follows:

      cdscache delete server_name



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




      The delete operation removes knowledge of a server that was
      specifically created from the local client's cache. The required
      server_name argument is the simple name of a cached server.  (An
      example of a simple name would be pelican, as opposed to a  cellrelative
 name like /.:/hosts/pelican.) You can delete only servers
      that you have specifically created with the cdscache create command.
      This operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission to the client system,
      /.:/hosts/hostname/cds-clerk.

      Examples    [Toc]    [Back]

      The following command removes knowledge of the server gumby from the
      client cache:

      dcecp> cdscache delete gumby
      dcecp>


    cdscache discard
      Discards the contents of the client cache.  The syntax is as follows:

      cdscache discard  [server_name]


      The discard operation discards information in the client cache on the
      host specified by server_name.  If you do not specify server_name, the
      operation discards the information from the client cache on the local
      host.  Only a single server name can be specified.  This operation
      returns an empty string on success.

      To perform the operation, cdscache discard does the following:


       1.  Brings down the client CDS.

       2.  Deletes a specific set of files.

       3.  Restarts the client CDS.


      During the process, all cached information is discarded.

      Privileges Required    [Toc]    [Back]

      You must have superuser (root) privileges on the client system.  No
      CDS permissions are required.




 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




      Examples    [Toc]    [Back]

      The following command discards the contents of the client cache on the
      local host:

      cecp> cdscache discard
      dcecp>


    cdscache dump
      Displays the entire contents of the client cache.  The syntax is as
      follows:

      cdscache dump


      The dump operation displays the contents of the client cache on the
      screen.

      Privileges Required    [Toc]    [Back]

      You must have superuser (root) privileges on the client system.  No
      CDS permissions are required.

      Examples    [Toc]    [Back]

      The following command displays the contents of the client cache to the
      screen:

      dcecp> cdscache dump
      Default timeout = 300 seconds
      CACHED DIRECTORIES*****************************************************
      /.../gumby1/cds_set_7_P_dir
          Master at /.../gumby1/yuric_ch
          Clearinghouse UID: d30d1770-6b05-11d0-b053-08000927749b
          Clearinghouse Address:
              ncadg_ip_udp:15.22.50.32[]
              ncacn_ip_tcp:15.22.50.32[]

      /.../gumby1/dirde1
          Master at /.../gumby1/yuric_ch
          Clearinghouse UID: d30d1770-6b05-11d0-b053-08000927749b
          Clearinghouse Address:
              ncadg_ip_udp:15.22.50.32[]
              ncacn_ip_tcp:15.22.50.32[]
                          .
                          .
                          .
      dcecp>





 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




    cdscache help
      Returns help information about the cdscache object and its operations.
      The syntax is as follows:

      cdscache help [operation | -verbose]


      Options    [Toc]    [Back]

      -verbose  Displays information about the cdscache object.


      Used without an argument or option, the cdscache help command returns
      brief information about each cdscache operation. The optional
      operation argument is the name of an operation about which you want
      detailed information. Alternatively, you can use the -verbose option
      for more detailed information about the cdscache object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the cdscache help command.

      Examples    [Toc]    [Back]

      dcecp> cdscache help
      create              Adds information about named server in local cds cache.
      delete              Removes information about named server from local cds cache.
      discard             Discards all cdsadv cache information on the specified host.
      dump                Dumps all information from local cds cache.
      show                Returns information stored in cds cache.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    cdscache operations
      Returns a list of the operations supported by the cdscache object. The
      syntax is as follows:

      cdscache operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the cdscache operations
      command.





 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




      Examples    [Toc]    [Back]

      dcecp> cdscache operations
      create delete discard dump show help operations
      dcecp>


    cdscache show
      Returns information about clearinghouses or servers stored in the
      cache.  The syntax is as follows:

      cdscache show server_name {-server | -clearinghouse}


      Options    [Toc]    [Back]

      -clearinghouse
                This option displays all the names and values of the
                attributes in the specified cached clearinghouse.  The
                following are valid attributes:


                Creation Time    [Toc]    [Back]
                          Specifies the time at which this clearinghouse was
                          added to the cache

                Miscellaneous Operations    [Toc]    [Back]
                          Specifies the number of operations other than read
                          and write (that is, skulks, new epochs, and so on)
                          performed by this client on the cached
                          clearinghouse

                Read Operations    [Toc]    [Back]
                          Specifies the number of lookup operations of any
                          sort performed by the client on the cached
                          clearinghouse

                Towers    Specifies the protocol sequence and network
                          address of the server that maintains the cached
                          clearinghouse

                Write Operations    [Toc]    [Back]
                          Specifies the number of write operations performed
                          by this client on the cached clearinghouse


      -server   This option displays address information of a server in the
                local client's cache.  The following attributes are valid:






 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 cdscache(1m)             Open Software Foundation              cdscache(1m)




                Name      The directory cell name

                Towers    The protocol sequence and network address of the
                          server node


      The show operation displays information about clearinghouses or
      servers stored in the cache. The required server_name argument is the
      simple name of a server or a CDS names of a clearinghouse for which
      you want to display information. You must use one of the
      -clearinghouse or -server options to select the information you want
      to display.

      Privileges Required    [Toc]    [Back]

      You must have r (read) permission to the CDS client.

      Examples    [Toc]    [Back]

      The following command displays all attributes of the cached
      clearinghouse /.:/claire_ch:

      dcecp> cdscache show /.:/claire_ch -clearinghouse
      {CH_Name /.../blue.cell.osf.org/claire_ch}
      {Created 1994-10-07-11:41:23.131}
      {Others 458}
      {Reads 150221}
      {Tower {ncacn_ip_tcp 130.105.4.158}}
      {Tower {ncadg_ip_udp 130.105.4.158}}
      {Writes 162}
      dcecp>


      The following command displays all attributes of the cached server
      pokey:

      dcecp> cdscache show pokey -server
      {CH_Name /.../terrapin_cell.osf.org/pokey_ch}
      {Tower {ncacn_ip_tcp 130.105.5.16}}
      {Tower {ncadg_ip_udp 130.105.5.16}}
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_clearinghouse(1m), dcecp_directory(1m),
      dcecp_link(1m), dcecp_object(1m).


 Hewlett-Packard Company            - 7 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_clock HP-UX A dcecp object that manages the clock on a local or remote host
dcecp_endpoint HP-UX A dcecp object that manages endpoint information in local RPC endpoint maps
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_rpcprofile HP-UX A dcecp object that manages an RPC profile entry in CDS
dcecp_dts HP-UX A dcecp object that manages a dtsd process
dcecp_rpcgroup HP-UX A dcecp object that manages an RPC group entry in CDS
dcecp_server HP-UX A dcecp object that manages DCE application servers
dcecp_link HP-UX A dcecp object that manages a soft link in CDS
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service