hostdata(1m) Open Software Foundation hostdata(1m)
NAME [Toc] [Back]
hostdata - A dcecp object that manages a DCE host's cell affiliation
information
SYNOPSIS [Toc] [Back]
hostdata catalog [host_name_list] [-simplename]
[-local] [-unauth]
hostdata create hostdata_name_list
{-attribute attribute_list | -attribute value}
[-ifname residual_hostdata_name | -local] [-entry] [-binary]
hostdata delete hostdata_name_list [-entry]
[-ifname residual_hostdata_name | -local]
hostdata help [operation | -verbose]
hostdata modify hostdata_name_list
{-change attribute_list | -attribute value}
[-ifname residual_hostdata_name | -local] [-binary]
hostdata operations
hostdata show hostdata_name_list
[-entry] [-binary]
[-ifname residual_hostdata_name | -local] [-unauth]
ARGUMENTS [Toc] [Back]
host_name_list
A list of one or more DCE host names specifying hosts for
which to catalog hostdata objects. Host names can be in any
of the following forms:
/.:/hosts/hostname
/.../cell_name/hosts/hostname
hosts/hostname
The name can also be a single string binding representing
the host with which to communicate. See hostdata_name_list
for more information.
hostdata_name_list
A list of one or more names of host data items. Usually
they are of the following form:
/.:/hosts/hostname/config/hostdata/name
Hewlett-Packard Company - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
The name can also be a single string binding representing
the host with which to communicate. For example:
{ncacn_ip_tcp 130.105.1.227}
A string binding is useful when the name service is not
operating and cannot translate the other forms of host data
item names. If you supply a single string binding, you
must use the -ifname option to specify the object's residual
name.
operation The name of the hostdata operation for which to display help
information.
DESCRIPTION [Toc] [Back]
The hostdata object represents a hostdata entry stored by dced on a
host that represents some data, usually a file. The data in the
hostdata object is represented by the hostdata/data attribute of the
hostdata entry. Remote manipulation of data in the hostdata object is
accomplished by the hostdata command. The names of these hostdata
objects are in the DCE namespace and are controlled by dced. Usually
they are of the following form:
/.:/hosts/hostname/config/hostdata/name
However, a shorthand notation referring to the local machine
consisting of just name can be used in some circumstances.
When the dced on the local machine is in partial service mode, you
must use the -local option to access the hostdata object. To access
the hostdata objects when dced is in partial service mode, specify
only the residual portion of the object name. For example, specify
name, not /.:/hosts/gumby/config/hostdata/name.
ATTRIBUTES [Toc] [Back]
uuid hexadecimal number
An internal identifier for the hostdata entry. Its value is
a Universal Unique Identifier (UUID). If not specified on
creation, one is generated by dcecp. This attribute cannot
be modified after creation.
annotation string
A human-readable comment field limited to Portable Character
Set (PCS) data. It cannot be modified after creation. This
attribute defaults to a null string (that is, blank).
storage string
A PCS string that identifies the name of the data
repository. In the current release of dced, it is a
Hewlett-Packard Company - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
filename. It is required and cannot be modified after
creation.
hostdata/data string
An attribute that represents the actual data. Its syntax is
a list of strings. The data can be viewed and modified in
two different modes, either as a string, or as binary data.
By default the string mode is used, but some of the
operations below accept a binary option to allow this
attribute to be displayed or modified in binary form. When
viewed as a string, each string in the list represents one
line in the hostdata file.
See the OSF DCE Administration Guide for more information about
hostdata attributes.
OPERATIONS [Toc] [Back]
hostdata catalog
Returns a list of the names of all hostdata objects on the specified
host. The syntax is as follows:
hostdata catalog [host_name_list] [-simplename]
[-local] [-unauth]
Options [Toc] [Back]
-simplename
Returns a list of hostdata entries without prepending the
cell name and name of the hostdata container.
-local Specifies that the command should operate on the local dced
hostdata object while the dced process is in a partialservice
state.
-unauth Specifies that the command should operate as if an
unauthenticated user is running it. This option is useful
for intercell access when the cell registries are not
connected.
The catalog operation returns a list of the names of all hostdata
objects on the specified host, in arbitrary order. The optional
host_name_list argument specifies objects on a foreign host. By
default, fully qualified names are returned. Use the -simplename
option to return object names without the prepended cell name and
hostdata container names.
Hewlett-Packard Company - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
Privileges Required [Toc] [Back]
You must have r (read) permission to the hostdata container on the
specified host
(/.:/hosts/host_name/config/hostdata/hostdata_container).
Examples [Toc] [Back]
dcecp> hostdata catalog
/.../gumby1/hosts/fire/config/hostdata/dce_cf.db
/.../gumby1/hosts/fire/config/hostdata/cell_name
/.../gumby1/hosts/fire/config/hostdata/pe_site
/.../gumby1/hosts/fire/config/hostdata/cds_attributes
/.../gumby1/hosts/fire/config/hostdata/cds_globalnames
/.../gumby1/hosts/fire/config/hostdata/host_name
/.../gumby1/hosts/fire/config/hostdata/cell_aliases
/.../gumby1/hosts/fire/config/hostdata/post_processors
/.../gumby1/hosts/fire/config/hostdata/svc_routing
/.../gumby1/hosts/fire/config/hostdata/krb.conf
/.../gumby1/hosts/fire/config/hostdata/dfs-cache-info
/.../gumby1/hosts/fire/config/hostdata/cds.conf
/.../gumby1/hosts/fire/config/hostdata/passwd_override
/.../gumby1/hosts/fire/config/hostdata/group_override
dcecp>
hostdata create
Creates a hostdata configuration object. The syntax is as follows:
hostdata create hostdata_name_list
{-attribute attribute_list | -attribute value}
[-ifname residual_hostdata_name | -local] [-entry] [-binary]
Options [Toc] [Back]
-attribute value
As an alternative to using the -attribute option with an
attribute list, you can specify individual attribute options
by prepending a hyphen (-) to any attributes listed in the
ATTRIBUTES section of this reference page.
-attribute attribute_list
Allows you to specify attributes by using an attribute list
rather than individual attribute options. The format of an
attribute list is as follows:
{{attribute value}...{attribute value}}
Hewlett-Packard Company - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
-binary Specifies that the value of the data attribute is in binary
form.
-local Specifies that the command should operate on the local dced
hostdata object while the dced process is in a partialservice
state.
-entry Only the configuration information that dced keeps is
created, not the actual hostdata.
-ifname Specifies the dced hostdata object to create.
The hostdata_name_list argument is a list of names of hostdata entries
to be created. The -attributes option specifies configuration
information for dced. The contents of the hostdata file can be
specified via the data attribute. If called with the -entry option,
the data attribute is not allowed. The value of the option is applied
to all elements of the argument list. The -ifname option is used to
identify the specific hostdata entry to create, but only when the
argument is a string binding representing a host, not a fully
qualified hostdata name. This operation returns an empty string on
success.
Privileges Required [Toc] [Back]
You must have w (write) permission to the hostdata container on the
host.
Examples [Toc] [Back]
dcecp> hostdata create file1 -storage /tmp/file1 -data {{first line}}
dcecp>
dcecp> hostdata show file1
{uuid 8484188a-eb85-11cd-91b1-080009251352}
{annotation {}}
{storage /tmp/file1}
{hostdata/data {first line}}
dcecp>
dcecp> cat /tmp/file1
first line
dcecp>
dcecp> hostdata create ncacn_ip_tcp:15.22.24.145 -ifname gumby_attr \
> -storage /tmp/gumby_file -data {{line one} {line two}}
dcecp>
Hewlett-Packard Company - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
hostdata delete
Deletes a hostdata entry and its data. The syntax is as follows:
hostdata delete hostdata_name_list [-entry]
[-ifname residual_hostdata_name | -local]
Options [Toc] [Back]
-entry Only the configuration information that dced keeps is
deleted, not the actual hostdata.
-local Specifies that the command should operate on the local dced
hostdata object while the dced process is in a partialservice
state.
-ifname Specifies the dced hostdata object to delete.
The hostdata_name_list argument is a list of names of hostdata entries
to be deleted in the order specified. If the -entry option is
present, only the configuration information that dced keeps is
deleted, not the actual hostdata. The -ifname option is used to
identify the specific hostdata entry to delete, but only when the
argument is a string binding representing a host, not the fully
qualified hostdata name. This operation returns an empty string on
success.
Privileges Required [Toc] [Back]
You must have d (delete) permission to the hostdata container on the
host.
Examples [Toc] [Back]
dcecp> hostdata delete file1
dcecp>
dcecp> hostdata delete ncacn_ip_tcp:15.22.24.145 -ifname gumby_attr
dcecp>
hostdata help
Returns help information about the hostdata object and its operations.
The syntax is as follows:
hostdata help [operation | -verbose]
Hewlett-Packard Company - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
Options [Toc] [Back]
-verbose Displays information about the hostdata object.
Used without an argument or option, the hostdata help command returns
brief information about each hostdata operation. The optional
operation argument is the name of an operation about which you want
detailed information. Alternatively, you can use the -verbose option
for more detailed information about the hostdata object itself.
Privileges Required [Toc] [Back]
No special privileges are needed to use the hostdata help command.
Examples [Toc] [Back]
dcecp> hostdata help
catalog Returns the list of hostdata object names.
create Creates a new hostdata configuration object.
delete Deletes a hostdata object and its associated data.
modify Modifies the data of a hostdata object.
show Returns the attributes of a hostdata object.
help Prints a summary of command-line options.
operations Returns a list of the valid operations for this command.
dcecp>
hostdata modify
This operation is used to change attributes of a hostdata entry,
including the hostdata itself. The syntax is as follows:
hostdata modify hostdata_name_list
{-change attribute_list | -attribute value}
[-ifname residual_hostdata_name | -local] [-binary]
Options [Toc] [Back]
-attribute value
As an alternative to using the -change option with an
attribute list, you can specify individual attribute options
by prepending a hyphen (-) to any attributes listed in the
ATTRIBUTES section of this reference page.
In the current version of DCE, only the data attribute can
be modified.
Hewlett-Packard Company - 7 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
-change attribute_list
Allows you to modify attributes by using an attribute list
rather than individual attribute options. The format of an
attribute list is as follows:
{{attribute value}...{attribute value}}
In the current version of DCE, only the data attribute can
be modified.
-binary Specifies that the value of the data attribute is in binary
form.
-local Specifies that the command should operate on the local dced
hostdata object while the dced process is in a partialservice
state.
-ifname Specifies the dced hostdata object to modify.
The argument is a list of names of hostdata entries to be modified.
If more than one is specified, all modifications specified are made to
each hostdata entry listed. In the current DCE Version, only the data
attribute can be modified and only by completely replacing it. The -
ifname option is used to identify the specific hostdata entry to
modify, but only when the argument is a string binding representing a
host, not the fully qualified hostdata name. This operation returns
an empty string on success.
Privileges Required [Toc] [Back]
You must have w (write) permission to the hostdata container on the
host.
Examples [Toc] [Back]
dcecp> hostdata modify file1 -data {new first line}
dcecp>
dcecp> hostdata show file1
{uuid cda3a184-eb85-11cd-91b1-080009251352}
{annotation {}}
{storage /tmp/file1}
{hostdata/data {new first line}}
dcecp>
dcecp> cat /tmp/file1
new first line
dcecp>
Hewlett-Packard Company - 8 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
dcecp> hostdata modify ncacn_ip_tcp:15.22.24.145 -ifname gumby_attr \
> -data {new improved line one}
dcecp>
hostdata operations
Returns a list of the operations supported by the hostdata object. The
syntax is as follows:
hostdata operations
The list of available operations is in alphabetical order except for
help and operations, which are listed last.
Privileges Required [Toc] [Back]
No special privileges are needed to use the hostdata operations
command.
Examples [Toc] [Back]
dcecp> hostdata operations
catalog create delete modify show help operations
dcecp>
hostdata show
Returns an attribute list of the hostdata entries specified in the
argument. The syntax is as follows:
hostdata show hostdata_name_list
[-entry] [-binary]
[-ifname residual_hostdata_name | -local] [-unauth]
Options [Toc] [Back]
-ifname Specifies the dced hostdata object for which to return the
value.
-entry Only the configuration information that dced keeps is
returned, not the actual hostdata.
-binary Specifies to return the value of the data attribute in
binary form.
-local Specifies that the command should operate on the local dced
hostdata object while the dced process is in a partialservice
state.
Hewlett-Packard Company - 9 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
hostdata(1m) Open Software Foundation hostdata(1m)
-unauth Specifies that the command should operate as if an
unauthenticated user is running it. This option is useful
for intercell access when the cell registries are not
connected.
The hostdata_name_list argument is a list of names of hostdata
entries. If called with the -entry option, the data attribute is not
returned. The -binary option can be specified to indicate that the
value of the data attribute should be returned in binary form. If the
argument is a list of entries, the output is concatenated into a
single list in the order specified. The -ifname option is used to
identify the specific hostdata entry to show, but only when the
argument is a string binding representing a host, not the fully
qualified hostdata name.
Privileges Required [Toc] [Back]
You must have r (read) permission to the hostdata container on the
specified host
(/.:/hosts/host_name/config/hostdata/hostdata_container).
Examples [Toc] [Back]
dcecp> hostdata show /.:/hosts/mars/config/hostdata/cell_name
{uuid 00174f6c-6eca-1d6a-bf90-0000c09ce054}
{annotation {Name of cell}}
{storage cell_name}
{hostdata/data /.../my_cell}
dcecp>
dcecp> hostdata show ncacn_ip_tcp:15.122.24.148 -ifname cell_name
{uuid 00174f6c-6eca-1d6a-bf90-0000c09ce054}
{annotation {Name of cell}}
{storage cell_name}
{hostdata/data /.../my_cell}
dcecp>
RELATED INFORMATION [Toc] [Back]
Commands: dcecp(1m), dced(1m).
Hewlett-Packard Company - 10 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96 [ Back ] |