*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_utc (1m)              
Title
Content
Arch
Section
 

Contents


 utc(1m)                  Open Software Foundation                   utc(1m)




 NAME    [Toc]    [Back]
      utc - A dcecp object that manipulates UTC timestamps

 SYNOPSIS    [Toc]    [Back]
      utc add timestamp relative_timestamp

      utc compare absolute_timestamp absolute_timestamp [-noinaccuracy]

      utc convert absolute_timestamp [-gmt]

      utc help [operation | -verbose]

      utc multiply relative_timestamp {integer | floating_point_factor}

      utc operations

      utc subtract timestamp timestamp


 ARGUMENTS    [Toc]    [Back]
      absolute_timestamp
                An International Organization for Standardization (ISO)
                compliant time format of the following form:

                CCYY-MMDD-hh:mm:ss.fff[+|-]hh:mmIsss.fff

                The Time Differential Factor (TDF) component [+|-]hh.mm, if
                present, indicates the offset from Universal Time
                Coordinated (UTC) time and implies local system time. The
                inaccuracy component Iss.fff, if present, specifies the
                duration of the time interval that contains the absolute
                time.

      floating_point_factor
                A floating-point number such as 53.234.

      integer   A whole number such as 79.

      operation The name of the utc operation for which to display help
                information.

      relative_timestamp
                A Distributed Time Service (DTS) timestamp of the following
                form:

                [-]DD-hh:mm:ss.fffIss.fff

                Relative times often omit fractions of seconds (the leftmost
                .fff sequence) and generally lack an inaccuracy component
                (Iss.fff). For example, a relative time of 21 days, 8 hours,
                and 15 minutes is expressed as 21-08:15:00.



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 utc(1m)                  Open Software Foundation                   utc(1m)




      timestamp A utc timestamp that can be a relative or absolute time.
                See the relative_timestamp and absolute_timestamp argument
                descriptions for the format of these timestamps.


 DESCRIPTION    [Toc]    [Back]
      The utc object lets you add, compare, and convert timestamps in DTS
      and ISO formats.

 OPERATIONS    [Toc]    [Back]
    utc add
      Adds two timestamps.  The syntax is as follows:

      utc add timestamp relative_timestamp


      The add operation returns the sum of two timestamps.  The timestamps
      can be two relative times or an absolute time and a relative time.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the utc add command.

      Examples    [Toc]    [Back]

      dcecp> utc add 1994-10-18-13:21:50.419-04:00I----- +0-00:02:00.000I-----
      1994-10-18-13:23:50.419-04:00I-----
      dcecp>


    utc compare
      Compares two absolute timestamps indicating the temporal order. The
      syntax is as follows:

      utc compare absolute_timestamp absolute_timestamp [-noinaccuracy]


      The compare operation compares two timestamps and returns -1 if the
      first is earlier, 1 if the second is earlier, and 0 if the difference
      is indeterminate. Specify the -noinaccuracy option to ignore
      inaccuracies in comparisons; in this case a return of 0 indicates the
      times are the same.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the utc compare command.

      Examples    [Toc]    [Back]

      dcecp> utc compare 1994-10-18-13:22:32.816-04:00I----- \
       1994-10-18-13:21:50.419-04:00I----- -noinaccuracy



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 utc(1m)                  Open Software Foundation                   utc(1m)




      1
      dcecp>


    utc convert
      Converts a timestamp from UTC to local time. The syntax is as follows:

      utc convert absolute_timestamp [-gmt]


      The convert operation accepts a timestamp and returns another
      timestamp that expresses the same time in the local time zone.  If
      called with the -gmt option it returns a Greenwich mean time (GMT)
      formatted timestamp.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the utc convert command.

      Examples    [Toc]    [Back]

      dcecp> utc convert 1994-10-18-13:22:32.816-00:00I-----
      1994-10-18-09:22:32.816-04:00I-----
      dcecp>

      dcecp> utc convert 1994-10-18-13:22:32.816-00:00I----- -gmt
      1994-10-18-13:22:32.816I-----
      dcecp>


    utc help
      Returns help information about the utc object and its operations.  The
      syntax is as follows:

      utc help [operation | -verbose]


      Options    [Toc]    [Back]


      -verbose  Displays information about the utc object.


      Used without an argument or option, the utc help command returns brief
      information about each utc operation. The optional operation argument
      is the name of an operation about which you want detailed information.
      Alternatively, you can use the -verbose option for more detailed
      information about the utc object itself.

      Privileges Required    [Toc]    [Back]




 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 utc(1m)                  Open Software Foundation                   utc(1m)




      No special privileges are needed to use the utc help command.

      Examples    [Toc]    [Back]

      dcecp> utc help
      add                 Adds a relative and absolute, or two relative, timestamps.
      compare             Compares two timestamps to determine which is earlier.
      convert             Converts a timestamp into the local timezone or GMT.
      multiply            Multiplies a relative timestamp by a number.
      subtract            Returns the difference between two timestamps.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    utc multiply
      Multiplies a relative time (a length of time) by an integer or
      floating-point factor. The syntax is as follows:

      utc multiply relative_timestamp {integer | floating_point_factor}


      The multiply operation accepts two arguments:  a relative timestamp
      and an integer or floating-point factor.  It multiplies the length of
      time (specified by the relative timestamp) by the integer or
      floating-point factor, returning the product as a relative timestamp.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the utc multiply command.

      Examples    [Toc]    [Back]

      dcecp> utc multiply +0-00:00:05.000I----- 3
      +0-00:00:15.000I-----
      dcecp>


    utc operations
      Returns a list of the operations supported by the utc object. The
      syntax is as follows:

      utc operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]





 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 utc(1m)                  Open Software Foundation                   utc(1m)




      No special privileges are needed to use the utc operations command.

      Examples    [Toc]    [Back]

      dcecp> utc operations
      add compare convert multiply subtract help operations
      dcecp>


    utc subtract
      Subtracts one timestamp from another, returning the difference as a
      relative timestamp.  The syntax is as follows:

      utc subtract timestamp timestamp


      The subtract operation returns the difference between two timestamps
      that express either an absolute time and a relative time, two relative
      times, or two absolute times.  Subtracting an absolute timestamp from
      a relative timestamp, however, is not allowed.  The return value is an
      absolute or relative timestamp, depending on how the command is used.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the utc subtract command.

      Examples    [Toc]    [Back]

      dcecp> utc subtract 1994-10-18-13:22:32.816-00:00I----- +0-00:00:15.000I-----
      1994-10-18-13:22:17.816+00:00I-----
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_clock(1m), dcecp_dts(1m), dtsd(1m).


 Hewlett-Packard Company            - 5 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_attrlist HP-UX A dcecp task object that manipulates attribute lists
dcecp_user HP-UX A dcecp task object that manipulates user information in a DCE cell
mcs Tru64 Manipulates object file comment sections
dcecp_object HP-UX A dcecp object that manages an object in CDS
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_server HP-UX A dcecp object that manages DCE application servers
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_dts HP-UX A dcecp object that manages a dtsd process
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service