*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_link (1m)              
Title
Content
Arch
Section
 

Contents


 link(1m)                 Open Software Foundation                  link(1m)




 NAME    [Toc]    [Back]
      link - A dcecp object that manages a soft link in CDS

 SYNOPSIS    [Toc]    [Back]
      link create link_name_list
      {-to target_name [-timeout expiration_time extension_time] |
      -attribute attribute_list}

      link delete link_name_list

      link help [operation | -verbose]

      link modify link_name_list
      {[-add attribute_list]
      [-remove attribute_list]
      [-change attribute_list]}

      link operations

      link show link_name_list [-schema]


 ARGUMENTS    [Toc]    [Back]
      link_name_list
                A list of one or more names of CDS soft links.

      operation The name of the link operation for which to display help
                information.


 DESCRIPTION    [Toc]    [Back]
      The link object represents a Cell Directory Service (CDS) soft link.
      A soft link in CDS contains an attribute that has a name that is the
      same as the name of the object the soft link points to.  The soft link
      contains several built-in attributes, but users are free to add their
      own attributes. Softlinks can point to objects, directories, and other
      soft links.

 ATTRIBUTES    [Toc]    [Back]
      The following CDS-defined attributes may be present in CDS link
      objects:


      CDS_CTS   Specifies the creation timestamp (CTS) of the soft link. The
                is a read-only DTS-style time stamp, which is set by the
                system.

      CDS_LinkTarget    [Toc]    [Back]
                Specifies the full name of the directory, object entry, or
                other soft link to which the soft link points.




 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




      CDS_LinkTimeout    [Toc]    [Back]
                Specifies a timeout value after which the soft link is
                either renewed or deleted.  Its value is a list of two
                elements enclosed in braces, as follows:

                {expiration_time extension_time}

                where:


                expiration_time
                          Is a date and time after which CDS checks for the
                          existence of the soft link's target and either
                          extends or deletes the soft link.  The value is
                          specified in the format yyyy-mm-dd-hh:mm:ss;
                          portions of it can be defaulted.

                extension_time
                          Is a period of time by which to extend the soft
                          link's expiration time (if the server has
                          validated that the target still exists). The value
                          is specified in the format ddd-hh:mm:ss; portions
                          of it can be defaulted.


      CDS_UTS   Specifies the timestamp of the most recent update to an
                attribute of the soft link.  The value is a read-only DTSstyle
 timestamp and is set by the system.


      See the OSF DCE Administration Guide for more information about link
      attributes.

 OPERATIONS    [Toc]    [Back]
    link create
      Creates a new soft link entry in CDS.  The syntax is as follows:

      link create link_name_list
      {-to target_name [-timeout expiration_time extension_time] |
      -attribute attribute_list}

      Options    [Toc]    [Back]

      -to target_name
                Specifies a single name for the links to point to.  If you
                do not use this option, you must specify the link target
                with the -attribute option.

      -timeout expiration_time extension_time
                Specifies the expiration time and extension period for all
                soft links named by the link_name_list argument.  The option



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




                syntax is as follows:

                {expiration_time extension_time}

                See ATTRIBUTES for more detailed information about link
                timeouts. If you omit the -timeout option, the link is
                permanent and must be explicitly deleted.

      -attribute attribute_list
                Allows you to specify attributes by using an attribute list.
                See ATTRIBUTES for more detailed information about link
                attributes.


      The create operation creates a new soft link entry in CDS. The
      required link_name_list argument is a list of one or more full CDS
      names of the soft links to be created. This operation returns an empty
      string on success.

      Privileges Required    [Toc]    [Back]

      You must have i (insert) permission to the directory in which you
      intend to create the soft link.

      Examples    [Toc]    [Back]

      The following command creates a soft link named
      /.:/sales/tokyo/price-server that points to an object entry named
      /.:/sales/east/price-server.  The expiration value indicates that CDS
      checks that the destination name /.:/sales/east/price-server still
      exists on June 25,1995, at 12:00 p.m.  If the destination name still
      exists, the soft link remains in effect another 90 days.  Thereafter,
      CDS will check that the destination name exists every 90 days.

      dcecp> link create /.:/sales/tokyo/price-server -to \
      > /.:/sales/east/price-server -timeout {1995-06-25-12:00:00 90-00:00:00}
      dcecp>


      You can enter the same information as above by using the -attributes
      option, as follows:

      dcecp> link create /.:/sales/tokyo/price-server -attribute { \
      > {CDS_LinkTarget /.:/sales/east/price-server} {CDS_LinkTimeout \
      > {expiration 1995-06-25-12:00:00} {extension 90-00:00:00}}}
      dcecp>


    link delete
      Removes a link entry from CDS.  The syntax is as follows:




 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




      link delete link_name_list


      The delete operation removes a link entry from CDS. This task is
      usually done through a client application.  The required
      link_name_list argument is a list of one or more full CDS names of the
      link entry to be removed.  This operation returns an empty string on
      success.

      Privileges Required    [Toc]    [Back]

      You must have d (delete) permission to the link entry or A (Admin)
      permission to the directory that stores the link entry.

      Examples    [Toc]    [Back]

      dcecp> link delete /.:/sales/tokyo/price-server
      dcecp>


    link help
      Returns help information about the link object and its operations. The
      syntax is as follows:

      link help [operation | -verbose]


      Options    [Toc]    [Back]

      -verbose  Displays information about the link object.


      Used without an argument or option, the link help command returns
      brief information about each link operation. The optional operation
      argument is the name of an operation about which you want detailed
      information. Alternatively, you can use the -verbose option for more
      detailed information about the link object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the link help command.

      Examples    [Toc]    [Back]

      dcecp> link help
      create              Creates the named link.
      delete              Deletes the named link.
      modify              Adds, removes or changes an attribute in the named link.
      show                Returns the attributes of a link.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.



 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




      dcecp>


    link modify
      Changes attributes in the specified soft links.  The syntax is as
      follows:

      link modify link_name_list
      {[-add attribute_list]
      [-remove attribute_list]
      [-change attribute_list]}


      Options    [Toc]    [Back]

      -add attribute_list
                Adds one or more new attributes to a soft link or adds
                values to existing attributes when values are not already
                present.  Add an attribute type with no value by specifying
                an attribute type with no value.

      -remove attribute_list
                Removes an entire attribute or some attribute values from a
                soft link.  If only the attribute type is specified after
                the option, the entire attribute is removed.  If an
                attribute type and value are specified, only that value is
                removed.  If an attribute or value is not present, an error
                is returned.

      -change attribute_list
                Changes one attribute value to another for a soft link. Each
                attribute in the list has its existing value replaced by the
                new value given in the attribute list.  For multi-valued
                attributes, all existing values are replaced by all the
                values listed for the attribute in the attribute list.  If
                an attribute or value is not present, an error is returned.


      The modify operation can be used to change two attributes of a soft
      link: CDS_LinkTarget and CDS_LinkTimeout.  The argument is a list of
      names of soft links to be operated on.  The operation takes the -add,
      -remove, and -change options to specify an attribute list to describe
      the changes.  All the modifications are performed on each soft link
      named in the argument.  This operation returns an empty string on
      success.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission to the link object.





 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




      Examples    [Toc]    [Back]

      The following example sets the link expiration time to 1998-01-20-
      12:00:00:00 and the extension time to 10 days:

      dcecp> link modify /.:/depts/emergency -change { \
      > {CDS_LinkTimeout {expiration 1998-01-20-12:00:00:00} {extension +10-0:0:0}}}
      dcecp>


    link operations
      Returns a list of the operations supported by the link object. The
      syntax is as follows:

      link operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the link operations command.

      Examples    [Toc]    [Back]

      dcecp> link operations
      create delete modify show help operations
      dcecp>


    link show
      Returns attribute information associated with specified link entries.
      The syntax is as follows:

      link show link_name_list [-schema]


      Options    [Toc]    [Back]

      -schema   This option returns whether an attribute is single or
                multi-valued.  The type of value is specific to a link,
                meaning that the same attribute can be single-valued on one
                link and multi-valued on another.


      The show operation displays attribute information associated with
      specified link entries. The required link_name_list argument is a list
      of one or more full CDS names of the soft links you want to show.  If
      more than one link is shown, the attributes of all the soft links are
      concatenated into one list.  The order of the returned attributes is



 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 link(1m)                 Open Software Foundation                  link(1m)




      the lexical order of the object identifiers (OIDs) of each attribute
      for each object.

      Privileges Required    [Toc]    [Back]

      You must have r (read) permission to the link entry.

      Examples    [Toc]    [Back]

      dcecp> link show /.:/depts/emergency
      {CDS_CTS 1994-07-11-17:47:59.755+00:00I0.000/00-00-c0-8a-df-56}
      {CDS_UTS 1994-07-11-17:52:44.698+00:00I0.000/00-00-c0-8a-df-56}
      {CDS_LinkTarget /.../my_cell.acme_health.org/depts/radiology}
      {CDS_LinkTimeout
       {expiration 1995-07-11-00:00:00.000}
       {extension +10-10:00:00.000I-----}}
      cecp>

      dcecp> link show /.:/gumby -schema
      {CDS-CTS single}
      {CDS-UTS single}
      {CDS-LinkTarget single}
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_clearinghouse(1m), dcecp_directory(1m),
      dcecp_object(1m).


 Hewlett-Packard Company            - 7 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_dts HP-UX A dcecp object that manages a dtsd process
dcecp_rpcprofile HP-UX A dcecp object that manages an RPC profile entry in CDS
dcecp_rpcgroup HP-UX A dcecp object that manages an RPC group entry in CDS
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_server HP-UX A dcecp object that manages DCE application servers
dcecp_registry HP-UX A dcecp object that manages a registry in the DCE Security Service
dcecp_principal HP-UX A dcecp object that manages a principal in the DCE Security Service
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service