*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> xopen_networking (7)              
Title
Content
Arch
Section
 

Contents


 xopen_networking(7)                                     xopen_networking(7)




 NAME    [Toc]    [Back]
      xopen_networking - X/Open Networking Interfaces

 DESCRIPTION    [Toc]    [Back]
      X/Open has defined XTI, Sockets, and IP Address Resolution interfaces
      in X/Open CAE Specification, Networking Services, Issue 4 (UNIX 95)
      and X/Open CAE Specification, Networking Services, Issue 5 (UNIX 98).
      For a detailed description of these interfaces, please refer to the
      above specifications or to the book Go Solo, which is published by
      Prentice Hall.  Go Solo also includes a CD ROM which contains the
      above specification to other SPEC 1170 man pages.

 COMPILING ENVIRONMENT    [Toc]    [Back]
      Using any of the Networking Services(XTI, sockets) requires
      _XOPEN_SOURCE to be defined and _XOPEN_SOURCE_EXTENDED to be defined
      with the value 1.

      The _XOPEN_SOURCE macro may be defined automatically by the
      compilation environment, but to ensure portability the application
      should define the macro either on the compilation command line, or at
      the beginning of each source module prior to the inclusion of any
      headers. The _XOPEN_SOURCE_EXTENDED macro will not be automatically
      defined by the compilation environment.

      The c89 and cc utilities recognize the additional -l operand for
      standard libraries:

           -l xnet             This operand makes visible all functions
                               referenced in the above specification by
                               having the linker search the appropriate
                               X/Open networking interface libraries.  If
                               you also specify the -l c operand to
                               explicitly specify the C library, you must
                               specify the -l xnet operand before you
                               specify the -l c operand.

 AUTHOR    [Toc]    [Back]
      X/Open XTI, Sockets, and IP Address Resolution interfaces were
      developed by X/Open Company Limited.

 SEE ALSO    [Toc]    [Back]
      XTI library functions:

      t_accept(3), t_alloc(3), t_bind(3), t_close(3), t_connect(3),
      t_error(3), t_free(3), t_getinfo(3), t_getprotaddr(3), t_getstate(3),
      t_listen(3), t_look(3), t_open(3), t_optmgmt(3), t_rcv(3),
      t_rcvconnect(3), t_rcvdis(3), t_rcvrel(3), t_rcvudata(3),
      t_rcvuderr(3), t_snd(3), t_snddis(3), t_sndrel(3), t_sndudata(3),
      t_strerror(3), t_sync(3), t_unbind(3).





 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 xopen_networking(7)                                     xopen_networking(7)




      Sockets Interfaces:

      accept(2), bind(2), close(2), connect(2), fcntl(2), fgetpos(3S),
      fsetpos(3S), ftell(3S), getpeername(2), getsockname(2), getsockopt(2),
      listen(2), lseek(2), poll(2), read(1), recv(2), recvfrom(2),
      recvmsg(2), select(2), send(2), sendmsg(2), sendto(2), setsockopt(2),
      shutdown(2), socket(2), socketpair(2), write(1).

      IP Address Resolution Interfaces:

      endhostent(3N), endnetent(3N), endprotoent(3N), endservent(3N),
      gethostbyaddr(3N), gethostname(3N), getnetbyaddr(3N),
      getprotobynumber(3N), getservbyport(3N), htonl(3N), inet_addr(3N),
      ntohl(3N), sethostent(3N), setnetent(3N), setprotoent(3N),
      setservent(3N).


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
altq OpenBSD kernel interfaces for manipulating output queues on network interfaces
altq NetBSD kernel interfaces for manipulating output queues on network interfaces
ifnet FreeBSD kernel interfaces for manipulating network interfaces
if_data FreeBSD kernel interfaces for manipulating network interfaces
ifaddr FreeBSD kernel interfaces for manipulating network interfaces
ifqueue FreeBSD kernel interfaces for manipulating network interfaces
netintro FreeBSD introduction to networking facilities
netintro IRIX introduction to networking facilities
netintro OpenBSD introduction to networking facilities
networking OpenBSD introduction to networking facilities
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service