*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> sd (4)              
Title
Content
Arch
Section
 

t(1)

Contents


 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



 NAME    [Toc]    [Back]
      sd - all objects that Software Distributor (SD) uses, their attributes
      and storage formats

 DESCRIPTION    [Toc]    [Back]
      The SD commands create, install, distribute and manage software
      objects (bundles, products, subproducts and filesets).  In addition,
      they define and manage other objects in support of the software
      administration tasks which users perform. This manual page describes
      the SD software object classes, their attributes, and the file formats
      used to store their definitions.

      For an overview of all SD commands, see the sd(5) manual page by
      typing: man 5 sd

      The objects described here conform to layout_version 1.0 of the IEEE
      Standard 1387.2: Software Administration (POSIX).  The previous SD
      layout_version 0.8 is also supported.  For more details, see
      swpackage(4) or the layout_version option in sd(5).

 OBJECT CLASSES    [Toc]    [Back]
      The SD object classes are:

           host      A machine at which software is installed, will be
                     installed, or is being managed. A host contains one or
                     more roots (installed filesystems) and zero or more
                     depots.

           depot     A directory location which contains software products
                     or bundles that are available for installation. It is a
                     customizable source of software used for direct
                     installation. It can also represent a distribution
                     medium (e.g. tape or CD-ROM) which contains products or
                     bundles available for installation.  Depot corresponds
                     to the distribution class defined in POSIX.

           media     Vehicle for software delivery. When a depot is located
                     on one or more media in layout_version=1.0, the unique
                     sequence number identifying each medium is in the media
                     class.

           root      A set of installed software objects, usually the
                     operational software installed in the primary root
                     filesystem, "/". It also represents the set of software
                     objects installed into an alternate root directory.
                     Root corresponds to the installed_software class
                     defined in POSIX.

           vendor    The vendor who packaged and distributed a product or
                     bundle.  It is an optional component of a product or a
                     bundle.



 Hewlett-Packard Company            - 1 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           category  A classification for a product or bundle, such as
                     "systems_management," "desktop," or "patch."

           bundle    A bundle is a way of encapsulating products,
                     subproducts and filesets into a single software object.
                     More than one bundle can contain the same software
                     objects. A bundle can be thought of as a particular
                     "configuration" of software. It is a convenient way to
                     group software objects together for easy selection.
                     Bundle is NOT a superset of product.

           product   A software object which vendors package and distribute,
                     and which users purchase and install.  A product
                     contains one or more filesets and zero or more
                     subproducts.  A product can also contain zero or more
                     control_files.

           subproduct
                     A subset or partitioning of a software product.  It is
                     an optional component of a product.  and contains one
                     or more filesets.

           fileset   A grouping of one or more files contained in a product
                     or sub-product.  It groups a subset of a product's
                     files into a manageable unit.  A fileset can also
                     contain zero or more control_files.

           file      The actual files that make up a fileset that get
                     installed, configured, and removed.

           control_files
                     The scripts developed by vendors to perform product- or
                     fileset-specific operations during various software
                     management tasks. Often called control_scripts.

 OBJECT ATTRIBUTES    [Toc]    [Back]
      The following tables summarize the valid attributes for each software
      object class. A subset of these attributes can be defined for an
      object when creating products or bundles with swpackage.  See
      swpackage(4) for details on this subset.

      The attribute value types are defined in the next section, "VALUE
      TYPES".

    Vendor-Defined Attributes    [Toc]    [Back]
      You can create your own software attributes when packaging software.
      Keywords in a product specification file that are not recognized by SD
      are preserved, along with their associated values, by being
      transferred to the resulting INDEX or INFO files created by
      swpackageor swcopy.  (Refer to swpackage(4) for more information on
      INDEX and INFO files.)



 Hewlett-Packard Company            - 2 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



      The keyword is a filename character string. The value associated with
      a keyword is processed as an attribute_value.  It can be continued
      across multiple input lines or can reference a file containing the
      value for the keyword.

      Vendor-defined attributes are noted during packaging or when modified
      with swmodify.  These attributes can be listed with swlist.

    Host Attributes    [Toc]    [Back]

     _______________________________________________________________________
     |Attribute         | Value Type       |  Size   | Example              |
     |__________________|__________________|_________|______________________|
     |machine_type      | uname_string     |  32     | ia64 hp server g4000 |
     |__________________|__________________|_________|______________________|
     |name              | one_line_string  |  64     | dist.hp.com          |
     |__________________|__________________|_________|______________________|
     |os_name           | uname_string     |  32     | HP-UX                |
     |__________________|__________________|_________|______________________|
     |os_release        | uname_string     |  32     | B.11.11              |
     |__________________|__________________|_________|______________________|
     |os_version        | uname_string     |  32     | C                    |
     |__________________|__________________|_________|______________________|
     |contained depots  | list of depot    |         |                      |
     |                  | objects          |         |                      |
     |__________________|__________________|_________|______________________|
     |contained roots   | list of root     |         |                      |
     |                  | directories      |         |                      |
     |__________________|__________________|_________|______________________|

           machine_type
                The host's machine and architecture designation. (See output
                of the model command.)

           name The official name of the network host.

           os_name
                The host's operating system name.  (uname -s).

           os_release
                The host's operating system release.  (uname -r).

           os_version
                The host's operating system version.  (uname -v).

           contained depots
                The depots registered at the host.

           contained roots
                The root filesystems registered on this system.




 Hewlett-Packard Company            - 3 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



    Depot Attributes    [Toc]    [Back]

    _________________________________________________________________________
    |Attribute            | Value Type        | Size | Example               |
    |_____________________|___________________|______|_______________________|
    |copyright            | multi_line_string | 8K   | "This depot ..."      |
    |_____________________|___________________|______|_______________________|
    |data_model_revision  | revision_string   | 64   | 2.40                  |
    |_____________________|___________________|______|_______________________|
    |description          | multi_line_string | 8K   | "This depot ..."      |
    |_____________________|___________________|______|_______________________|
    |dfiles               |  tag_string       | 64   |  dfiles               |
    |_____________________|___________________|______|_______________________|
    |layout_version       | revision_string   | 64   | 1.0                   |
    |_____________________|___________________|______|_______________________|
    |mod_date             | one_line_string   | 64   | Tue Jun 22 12:52:09   |
    |                     |                   |      | 2001                  |
    |_____________________|___________________|______|_______________________|
    |mod_time             | unsigned_integer  |      | 740774837             |
    |_____________________|___________________|______|_______________________|
    |name_max             | unsigned_integer  |      | 255                   |
    |_____________________|___________________|______|_______________________|
    |number               | one_line_string   | 64   | B2358-13601           |
    |_____________________|___________________|______|_______________________|
    |path_max             | unsigned_integer  |      | 1023                  |
    |_____________________|___________________|______|_______________________|
    |pfiles               | tag_string        | 64   | pfiles                |
    |_____________________|___________________|______|_______________________|
    |tag                  | tag_string        | 64   | APPLICATIONS_CD       |
    |_____________________|___________________|______|_______________________|
    |title                | one_line_string   | 256  | Applications Software |
    |_____________________|___________________|______|_______________________|
    |uuid                 | one_line_string   | 64   | 25CA7C86-6F0C-9353    |
    |_____________________|___________________|______|_______________________|
    |contained bundles    | list of bundle    |      |                       |
    |                     | objects           |      |                       |
    |_____________________|___________________|______|_______________________|
    |contained products   | list of product   |      |                       |
    |                     | objects           |      |                       |
    |_____________________|___________________|______|_______________________|
    |contained media      | media object      |      |                       |
    |_____________________|___________________|______|_______________________|
    |contained vendors    | vendor objects    |      |                       |
    |_____________________|___________________|______|_______________________|
    |contained categories | category objects  |      |                       |
    |_____________________|___________________|______|_______________________|

           copyright
                The copyright information for the depot or tape.





 Hewlett-Packard Company            - 4 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           data_model_revision
                The HP specific format revision used to store the depot
                definition.

           description
                The multi-paragraph description of the distribution
                depot/tape.

           dfiles
                The name of a directory that contains any attributes that
                must be stored as files.

           layout_version
                The version of the IEEE Standard 1387.2
                (1.0 or 0.8) to which the HP-specific data_model_revision
                conforms.

           mod_date
                The string format of the mod_time.

           mod_time
                The time of the last operation performed on the depot.

           name_max
                The maximum length of file basenames in the depot.

           number
                The part or manufacturing number of the depot/tape.

           path_max
                The maximum length of file pathnames in the depot.

           pfiles
                The name of a directory that contains any product
                control_files or any product attributes that must be stored
                as files.

           tag  The identifier (short name) for the distribution depot/tape.

           title
                The full name (one-line description) of the distribution
                depot/tape.

           uuid The depot's Universal Unique Identifier (UUID).

           contained bundles
                The bundles available from the depot.

           contained products
                The products available from the depot.




 Hewlett-Packard Company            - 5 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           contained media
                The object defining the sequence number used to identify
                each medium.

           contained vendors
                The objects defining a vendor object that is associated with
                subsequent bundle and product objects that define a
                vendor_tag attribute.

           contained categories
                The objects defining a category object that is associated
                with subsequent software objects and define a category_tag
                attribute.

    Media Attributes    [Toc]    [Back]
      Generated by swpackage.


               ____________________________________________________
               |Attribute       | Value Type      | Size | Example |
               |________________|_________________|______|_________|
               |sequence_number | one_line_string |  64  |  1      |
               |________________|_________________|______|_________|

           sequence_number
                For a multiple tape distribution, this attribute defines the
                unique sequence_number of each medium.



























 Hewlett-Packard Company            - 6 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



    Root Attributes    [Toc]    [Back]

     _______________________________________________________________________
     |Attribute            | Value Type        | Size | Example             |
     |_____________________|___________________|______|_____________________|
     |data_model_revision  | revision_string   | 64   | 2.40                |
     |_____________________|___________________|______|_____________________|
     |description          | multi-line_string | 2048 | "This root is ..."  |
     |_____________________|___________________|______|_____________________|
     |dfiles               | tag_string        | 64   |  dfiles             |
     |_____________________|___________________|______|_____________________|
     |layout_version       | revision_string   | 64   | 1.0                 |
     |_____________________|___________________|______|_____________________|
     |mod_date             | one_line_string   | 64   | Mon Jun 14 13:01:19 |
     |                     |                   |      | 2001                |
     |_____________________|___________________|______|_____________________|
     |mod_time             | unsigned_integer  |      | 740774837           |
     |_____________________|___________________|______|_____________________|
     |path                 | one_line_string   | 256  | /xx/xx/xx           |
     |_____________________|___________________|______|_____________________|
     |pfiles               | tag_string        | 64   | pfiles              |
     |_____________________|___________________|______|_____________________|
     |root_type            | one_line_string   | 256  | shared              |
     |_____________________|___________________|______|_____________________|
     |contained bundles    | list of bundle    |      |                     |
     |                     | objects           |      |                     |
     |_____________________|___________________|______|_____________________|
     |contained products   | list of product   |      |                     |
     |                     | objects           |      |                     |
     |_____________________|___________________|______|_____________________|
     |contained vendors    | vendor objects    |      |                     |
     |_____________________|___________________|______|_____________________|
     |contained categories | category objects  |      |                     |
     |_____________________|___________________|______|_____________________|

           data_model_revision
                The HP specific format revision used to store the root
                definition.

           description
                A multi-line description of the root.

           layout_version
                The version of the IEEE Standard 1387.2 (1.0 or 0.8) to
                which the HP-specific data_model_revision conforms.

           mod_date
                The string format of the mod_time.

           mod_time
                The time of the last operation performed on the root.



 Hewlett-Packard Company            - 7 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           path The path to the root.

           root_type
                The type of root: shared, private or none.

           contained bundles
                The bundles installed into the root.

           contained products
                The products installed into the root.

           contained vendor
                The object defining a vendor object that is associated with
                subsequent bundle and product objects that define a
                vendor_tag attribute.

           contained category
                The object defining a category object that is associated
                with subsequent software objects that define a category_tag
                attribute.

    Vendor Attributes    [Toc]    [Back]

      ______________________________________________________________________
      |Attribute    |  Value Type        |  Size  |  Example                |
      |_____________|____________________|________|_________________________|
      |description  | multi_line_string  | 8K     | "This vendor ..."       |
      |_____________|____________________|________|_________________________|
      |title        | one_line_string    | 256    | Hewlett-Packard Company |
      |_____________|____________________|________|_________________________|
      |tag          | tag_string         | 64     | HP                      |
      |_____________|____________________|________|_________________________|
      |uuid         | one_line_string    | 64     | 1234567-CDEF-0123-4569  |
      |_____________|____________________|________|_________________________|

           description
                The multi-paragraph description of the vendor.

           tag  The identifier (short name) for the vendor.  Used to
                associate a vendor object with subsequent product or bundle
                objects having a vendor_tag attribute of the same value.

           title
                The full name (one-line description) for the vendor.

           uuid The vendor's Universal Unique Identifier (UUID).

      When listing the attributes of a vendor associated with the specified
      product or bundle using swlist, the option -a vendor lists all of the
      vendor attributes. The option -a vendor.attribute can be used to list
      specific vendor attributes (e.g.  -a vendor.title).



 Hewlett-Packard Company            - 8 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



      Note that the vendor specification is not the same as vendor-defined
      attributes described in the "Vendor-Defined Attributes" section.
      Vendor specification describes who is providing the software. Vendordefined
 attributes associate extra miscellaneous data with the
      software.

    Category Attributes    [Toc]    [Back]

     _______________________________________________________________________
     |Attribute    |  Value Type         |  Size  |  Example                |
     |_____________|_____________________|________|_________________________|
     |description  |  multi_line_string  |  8K    |  normal patches         |
     |_____________|_____________________|________|_________________________|
     |revision     |  revision_string    |  64    |  0.0                    |
     |_____________|_____________________|________|_________________________|
     |tag          |  tag_string         |  64    |  normal_patch           |
     |_____________|_____________________|________|_________________________|
     |title        |  one_line_string    |  256   |  patches for normal use |
     |_____________|_____________________|________|_________________________|

           description
                A more detailed description of the category.

           tag  A short name identifying the category. Each category must
                have a unique tag. This attribute has no default value.  The
                category tag patch is reserved. When is_patch is set to true
                for a software object, a built-in category_tag attribute of
                value patch is automatically included.

           title
                A longer name of the category used for presentation
                purposes.

           revision
                Determines which category object definition to maintain in a
                depot when a definition being installed or copied does not
                match a definition already in the depot with the same
                category_tag.  The category definition with the higher
                revision is maintained.















 Hewlett-Packard Company            - 9 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



    Bundle and Product Attributes    [Toc]    [Back]
           +    Attributes marked with a + apply only to the product class.

           +    Attributes marked with a - apply only to the bundle class.

           +    Attributes marked with a * determine the uniqueness of a
                product or bundle object instance.  Their values may also be
                of the type version_component when used in a version
                component of a software specification.













































 Hewlett-Packard Company           - 10 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



   ____________________________________________________________________________
    Attribute              Value Type            Size    Example
   ____________________________________________________________________________
    + all_filesets          one-line list of             commands agent
                            tag_string values            data man
   ____________________________________________________________________________
    * architecture         one_line_string*      64      HP-UX_B.11.11_32/64
   ____________________________________________________________________________
     category_tag          tag_string            64      normal
   ____________________________________________________________________________
    - contents             repeatable list of    8K      foo.bar,r=1.0,a=,v=HP
                           software_specs                x.y,r=2.0,a=,v=
   ____________________________________________________________________________
     control_directory     path_string           255     SD
   ____________________________________________________________________________
     copyright             multi_line_string     8K      "This product ..."
   ____________________________________________________________________________
     create_date           one_line_string       64      Mon Jun 14 13:01:19
   ____________________________________________________________________________
     create_time           unsigned_integer              740084479
   ____________________________________________________________________________
     data_model_revision   revision_string       64      2.40
   ____________________________________________________________________________
     description           multi_line_string     8K      "This product ..."
   ____________________________________________________________________________
     directory             path_string           1024
   ____________________________________________________________________________
     install_date          one_line_string       16      200102241212.34
   ____________________________________________________________________________
     install_source        one_line_string       1024    zook.com:/depot
   ____________________________________________________________________________
     install_type          one_line_string       16      physical
   ____________________________________________________________________________
     instance_id           tag_string            64      1
   ____________________________________________________________________________
     is_locatable          boolean               8       true
   ____________________________________________________________________________
     is_patch              boolean               8       true
   ____________________________________________________________________________
     layout_version        revision_string       64      1.0
   ____________________________________________________________________________
    * location             path_string           1024    /
   ____________________________________________________________________________
     machine_type          uname_string          64      ia64*
   ____________________________________________________________________________
     mod_date              one_line_string       64      Mon Jun 14 13:01:19
                                                         2001
   ____________________________________________________________________________
     mod_time              unsigned_integer              740084479
   ____________________________________________________________________________
     number                one_line_string       64      J2326AA



 Hewlett-Packard Company           - 11 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



   ____________________________________________________________________________
   | os_name             | uname_string        | 64    | HP-UX                 |
   |_____________________|_____________________|_______|_______________________|
   | os_release          | uname_string        | 64    | ?.11.*                |
   |_____________________|_____________________|_______|_______________________|
   | os_version          | uname_string        | 64    | [A-Z]                 |
   |_____________________|_____________________|_______|_______________________|
   |+ postkernel         | path_string         | 255   | /usr/bin/kernel_build |
   |_____________________|_____________________|_______|_______________________|
   |  qualifier          | one_line_string     | 64    | "My product"          |
   |_____________________|_____________________|_______|_______________________|
   |+ readme             | multi_line_string   | 1024K | < README              |
   |_____________________|_____________________|_______|_______________________|
   |* revision           | revision_string     | 64    | 2.0                   |
   |_____________________|_____________________|_______|_______________________|
   | share_link          | one_line_string     | 256   | "sbin"                |
   |_____________________|_____________________|_______|_______________________|
   | size                | unsigned_integer    |       | 14638872              |
   |_____________________|_____________________|_______|_______________________|
   | software_spec       | software_spec       |       | SD,r=2.0              |
   |_____________________|_____________________|_______|_______________________|
   |* tag                | tag_string          | 64    | SD                    |
   |_____________________|_____________________|_______|_______________________|
   | title               | one_line_string     | 256   | Software Distributor  |
   |_____________________|_____________________|_______|_______________________|
   |* vendor_tag         | tag_string          | 64    | HP                    |
   |_____________________|_____________________|_______|_______________________|
   |+ contained control  | list of control     |       |                       |
   |  scripts            | script objects      |       |                       |
   |_____________________|_____________________|_______|_______________________|
   |+ contained          | list of fileset     |       |                       |
   |  filesets           | objects             |       |                       |
   |_____________________|_____________________|_______|_______________________|
   |+ contained          | list of subproduct  |       |                       |
   |  subproducts        | objects             |       |                       |
   |_____________________|_____________________|_______|_______________________|

           all_filesets
                All the filesets originally packaged into the product.

           architecture
                The target system(s) on which the product will run.

           category_tag
                A repeatable tag-based attribute identifying a set of
                categories of which the software object is a member. This is
                used as a selection mechanism and can be used independent of
                patches. The default value is an empty list or patch if the
                is_patch attribute is set to true.  The category tag patch
                is reserved.




 Hewlett-Packard Company           - 12 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



                Like vendor_tag, this attribute associates this product or
                bundle with a category object containing additional
                information about the category (for example, a one-line
                title definition and a description of the category).

           contents
                The list of software_specs for a bundle. (Bundles can
                contain other bundles.) Fully qualified software specs at
                the fileset level are recommended when defining packages.
                (Applies to bundles only).

           control_directory
                The relative pathname to the product catalog directory
                within the depot/root catalog that contains control scripts
                for the product.

           copyright
                The copyright information for the product.

           create_date
                The string format of the create_time.

           create_time
                The time at which the bundle or product was created.

           data_model_revision
                The format revision used to store the product definition.

           directory
                The default pathname in which the product's files will be
                installed.

           description
                The multi-paragraph description of the product.

           install_date
                The installation date of the product or bundle.

           install_source
                The source from which the product was installed.

           install_type
                The type of installation - "physical" or "NFS_mount".

           instance_id
                The secondary identifier for products which have the same
                tag (or truncated tag) value.

           is_locatable
                Defines whether (or not) the product can be installed into
                an arbitrary directory.



 Hewlett-Packard Company           - 13 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           is_patch
                Identifies a software object as a patch.  The default value
                is false.  When set to true, a built-in category_tag
                attribute of value patch is automatically included.

           layout_version
                The version of the IEEE Standard 1387.2 (1.0 or 0.8) to
                which the HP-specific data_model_revision conforms.

           location
                The installed pathname of the product.

           machine_type
                The machine(s) on which the product will run.

           mod_date
                The string format of the mod_time.

           mod_time
                The time of the last operation performed on the product.

           number
                The part or order number for the product.

           os_name
                The operating system(s) on which the product will run.

           os_release
                The operating system release(s) on which the product will
                run.

           os_version
                The operating system versions(s) on which the product will
                run.

           postkernel
                The path to a script that is run after kernel filesets are
                installed.

           qualifier
                A user-specified name that identifies a product or set of
                product versions. Can be set using swmodify and used in
                software_specs with other commands.

           readme
                The most recent information for the product.

           revision
                The revision (release number, version number) of the
                product.




 Hewlett-Packard Company           - 14 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           share_link
                Sharing point(s) for product.

           size The size of the product in bytes.

           software_spec
                The fully qualified software specification for the bundle or
                product.  This attribute can be used to identify a unique
                bundle or product.

           tag  The identifier (short name) for the product.

           title
                The full name (one-line description) of the product.

           vendor_tag
                Associates this product or bundle with a vendor object
                containing additional attributes describing the vendor. The
                vendor object must have a matching tag attribute.

           contained control scripts
                The scripts defined for the product.

           contained filesets
                The fileset defined for the product.

           contained subproducts
                The subproducts defined for the product.

    Subproduct Attributes    [Toc]    [Back]

    _________________________________________________________________________
    |Attribute      | Value Type              | Size | Example               |
    |_______________|_________________________|______|_______________________|
    |contents       | repeatable list of      |      | commands data man     |
    |               | tag_string values       |      | commands data man     |
    |_______________|_________________________|______|_______________________|
    |description    | multi_line_string       | 8K   | "This subproduct ..." |
    |_______________|_________________________|______|_______________________|
    |size           | unsigned_integer        |      | 14638872              |
    |_______________|_________________________|______|_______________________|
    |software_spec  | software_specification  |      | Networking.Run,r=1.0  |
    |_______________|_________________________|______|_______________________|
    |tag            | tag_string              | 64   | Manager               |
    |_______________|_________________________|______|_______________________|
    |title          | one_line_string         | 256  | Management Utilities  |
    |_______________|_________________________|______|_______________________|

           contents
                A list of the filesets or subproducts that make up the
                subproduct.



 Hewlett-Packard Company           - 15 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           description
                The multi-paragraph description of the subproduct.

           size The size of the subproduct in bytes.

           software_spec
                The full software specification for the subproduct.  This
                attribute can be used to identify a unique subproduct.

           tag  The identifier (short name) for the subproduct.

           title
                The full name (one-line description) of the subproduct.

    Fileset Attributes    [Toc]    [Back]







































 Hewlett-Packard Company           - 16 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



     ________________________________________________________________________
      Attribute            Value Type             Size    Example
     ________________________________________________________________________
      ancestor             repeatable list of             oldprod.fs
                           software specs
     ________________________________________________________________________
      applied_patches      software_spec                  product.fileset,
                                                          version
     ________________________________________________________________________
      architecture         one_line_string        64      HP-UX_B.11.11
                                                          _32/64
     ________________________________________________________________________
      category_tag         tag_string             64      patch_normal
     ________________________________________________________________________
      control_directory    path_string            255     SD
     ________________________________________________________________________
      corequisites         repeatable list of             SD.man
                           software_specs
     ________________________________________________________________________
      create_date          one_line_string        64      Mon Jun 14
                                                          13:01:19 2001
     ________________________________________________________________________
      create_time          unsigned_integer               740084479
     ________________________________________________________________________
      data_model_          revision_string        64      2.40
      revision
     ________________________________________________________________________
      description          multi_line_string      8K      "This fileset ..."
     ________________________________________________________________________
      exrequisites         repeatable list of             SD.man
                           software_specs
     ________________________________________________________________________
      install_date         one-line string        16      200102241414.34
     ________________________________________________________________________
      install_source       one_line_string        1024    zook.com:/depot
     ________________________________________________________________________
      instance_id          tag_string                     1
     ________________________________________________________________________
      is_kernel            boolean                8       false
     ________________________________________________________________________
      is_locatable         boolean                8       true
     ________________________________________________________________________
      is_packaged_         boolean                8       false
      in_place
     ________________________________________________________________________
      is_patch             boolean                8       true
     ________________________________________________________________________
      is_reboot            boolean                8       false
     ________________________________________________________________________
      is_secure            boolean                8       false
     ________________________________________________________________________



 Hewlett-Packard Company           - 17 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



      is_sparse            boolean                8       false
     ________________________________________________________________________
      location             path_string            1024    /
     ________________________________________________________________________
      machine_type         uname_string           64      ia64*
     ________________________________________________________________________
      media_sequence_      unsigned_integer               1
      number
     ________________________________________________________________________
      mod_date             one_line_string        64      Mon Jun 14
                                                           13:01:19 2001
     ________________________________________________________________________
      mod_time             unsigned_integer               740084479
     ________________________________________________________________________
      os_name              uname_string           64      HP-UX
     ________________________________________________________________________
      os_release           uname_string           64      ?.11.*
     ________________________________________________________________________
      os_version           uname_string           64      ?
     ________________________________________________________________________
      patch_state          patch_state_string     16      applied
     ________________________________________________________________________
      pose_as_os_name      uname string           64      HP-UX:64
     ________________________________________________________________________
      pose_as_os_          uname string           64      B.11.11
      release
     ________________________________________________________________________
      prerequisites        repeatable list of             SD.agent
                           software_specs
     ________________________________________________________________________
      revision             revision_string        64      2.15
     ________________________________________________________________________
      size                 unsigned_integer               14638872
     ________________________________________________________________________
      state                state_enumeration              corrupt
     ________________________________________________________________________
      software_spec        software_spec                  Networking.Run,
                                                          r=1.0
     ________________________________________________________________________
      superseded_by        software_spec                  product.fileset,
                                                          version
     ________________________________________________________________________
      supersedes           software_spec                  product.fileset,
                                                          fr=revision
     ________________________________________________________________________
      tag                  tag_string             64      commands
     ________________________________________________________________________
      title                one_line_string        256     Commands
     ________________________________________________________________________
      contained control    list of control
       scripts             script objects



 Hewlett-Packard Company           - 18 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



     ________________________________________________________________________
     |contained files    | list of file objects |       |                    |
     |___________________|______________________|_______|____________________|
     |___________________|______________________|_______|____________________|

           ancestor
                A list of filesets that will match the current fileset when
                installed on a target system if the match_target
                installation option is specified. Also determines the base
                to which a patch is applied. (Note that an ancestor
                attribute is not the same as a corequisite, exrequisite, or
                prerequisite.)

           applied_patches
                Determines the list of patches that have been applied to a
                base fileset. This attribute applies to installed base
                (non-patch) software only.

           architecture
                Describes the target system(s) on which the fileset will run
                if filesets for multiple architectures are included in a
                single product. Provides a human-readable summary of the
                four uname(1) attributes which define the exact target
                system(s) the fileset supports. Most filesets do not include
                an architecture; only a product architecture need be
                defined.

           category_tag
                A repeatable tag-based attribute identifying a set of
                categories of which the software object is a member. This is
                used as a selection mechanism and can be used independent of
                patches. The default value is an empty list or patch if the
                is_patch attribute is set to true.  The category tag patch
                is reserved.

                Like vendor_tag, this attribute can be used as a pointer to
                a category object that contains additional information about
                the category (for example, a one-line title definition and a
                description of the category).

           control_directory
                The relative pathname to the fileset catalog directory in
                the product catalog that contains the control_scripts for
                the fileset.

           corequisites
                A list of dependencies on software that must be installed
                before this software is run.

           data_model_revision
                The format revision used to store the fileset definition.



 Hewlett-Packard Company           - 19 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           description
                The multi-paragraph description of the fileset.

           exrequisites
                A list of dependencies on software that may not be installed
                when this software is installed.

           install_date
                The date the fileset was installed.

           install_source
                The source from which the product was installed.

           instance_id
                The secondary identifier for filesets which have the same
                tag (or truncated tag) value.

           is_kernel
                Defines whether or not the fileset contains kernel files.

           is_locatable
                Defines whether or not the fileset can be installed into an
                arbitrary directory.

           is_packaged_in_place
                For a fileset within a depot, this attribute defines whether
                or not the fileset is packaged in place. If true, then the
                fileset's contents are actually references to the original
                source files used to construct the fileset.

           is_patch
                Identifies a software object as a patch.  The default value
                is false.  When set to true, a built-in category_tag
                attribute of value patch is automatically included.

           is_reboot
                Defines whether or not the fileset requires a reboot after
                install.

           is_secure
                Defines whether or not the fileset is encrypted on a CD-ROM
                media, requiring a codeword to install.

           is_sparse
                Indicates that a fileset contains only a subset of files in
                the base (ancestor) fileset and that the contents are to be
                merged with the base fileset. The default value is false.
                If the is_patch attribute is true, is_sparse is also set to
                true for the fileset, although it can be forced to false.





 Hewlett-Packard Company           - 20 -    HP-UX 11i Version 1.6: Jul 2002






 sd(4)                                                                 sd(4)
                           Hewlett-Packard Company



           location
                The installed pathname of the fileset, derived from the
                product location.

           machine_type
                Defines the machine(s) on which the product will run if a
                fileset architecture has been defined. (If not specified,
                swpackage assigns a value of "*", meaning the fileset runs
                on all machines.) If there are multiple machine platforms,
                use wildcards or the '|' character to identify them. This
                attribute should pattern match the output of the model
                command on the supported target machine(s).

           media_sequence_number
                For a multiple tape distribution, defines the tape on which
                the fileset is archived.

           mod_date
                The string format of the mod_time.

           mod_time
                The time of the last operation performed on the fileset.

           os_name
                Defines the operating system(s) on which the product will
                run if a fileset architecture has been defined. (If not
                specified, swpackage assigns a value of "*", meaning the
                fileset runs on all operating systems.) If there are
                multiple operating systems, use wildcards or the '|'
                character to identify them. This attribute should pattern
                match to the value of uname -s on the supported target
                system(s).

           os_release
                Defines the operating system release(s) on which the product
                will run if a fileset architecture has been defined.  (If
                not specified, swpackage assigns a value of "*", meaning the
                fileset runs on all releases.) If there are multiple
                operating system releases, use wildcards or the '|'
                character to identify them. This attribute should pattern
                match to the value of uname -r 

 Similar pages
Name OS Title
sd HP-UX Software Distributor, commands to create, distribute, install, monitor, and manage software
volmake Tru64 Create Logical Storage Manager objects
attr IRIX manipulate Extended Attributes on filesystem objects
swcopy HP-UX install and configure software products; software products for subsequent installation or distribution; respec
swinstall HP-UX install and configure software products; software products for subsequent installation or distribution; respec
volunmigrate Tru64 Moves AdvFS domain storage from physical storage to LSM volumes (volmigrate) or from LSM volumes to ...
volmigrate Tru64 Moves AdvFS domain storage from physical storage to LSM volumes (volmigrate) or from LSM volumes to ...
nroff Tru64 Formats text
perlform OpenBSD Perl formats
perlform IRIX Perl formats
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service