*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> term (5)              
Title
Content
Arch
Section
 

Contents


 term(5)                                                             term(5)
                               ENHANCED CURSES



 NAME    [Toc]    [Back]
      term - terminal capabilities

 SYNOPSIS    [Toc]    [Back]
      #include <term.h>

 DESCRIPTION    [Toc]    [Back]
      The following data type is defined through typedef:

           TERMINAL    An opaque representation of the capabilities for a
                       single terminal from the terminfo database.

      The <term.h> header provides a declaration for the following object:
      cur_term . It represents the current terminal record from the terminfo
      database that the application has selected by calling set_curterm().

      The <term.h> header contains the variable names listed in the Variable
      column in the table in Defined Capabilities in terminfo(4).

      The following are declared as functions, and may also be defined as
      macros:

           int        del_curterm(TERMINAL *oterm);
           int        putp(char *const str);
           int        restartterm(char *term, int fildes, int *errret);
           TERMINAL * set_curterm(TERMINAL *nterm);
           int        setupterm(char *term, int fildes, int *errret);
           int        tgetent(char *bp, char *const name);
           int        tgetflag(char id[2]);
           int        tgetnum(char id[2]);
           char *     tgetstr(char id[2], char **area);
           char *     tgoto(char *const cap, int col, int row);
           int        tigetflag(char *capname);
           int        tigetnum(char *capname);
           char *     tigetstr(char *capname);
           char *     tparm(char *cap, long p1, long p2, long p3, long p4,
                            long p5, long p6, long p7, long p8, long p9);
           int        tputs(char *const str, int affcnt, int (*putfunc)(int));

 SEE ALSO    [Toc]    [Back]
      terminfo(4), printf(1), putp(3X), tigetflag(3X), tgetent(3X),
      <curses.h>.

 CHANGE HISTORY    [Toc]    [Back]
      First released in X/Open Curses, Issue 4.


 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
cap_from_text IRIX convert a POSIX capabilities string to internal form, convert capabilities to a POSIX capabilities string, or
cap_acquire IRIX make permitted set capabilities effective or remove effective capabilities
termios Linux get and set terminal attributes, line control, get and set baud rate, get and set terminal foregroun...
ct HP-UX spawn getty to a remote terminal (call terminal)
cap_get_proc IRIX get or set process capabilities
capget Linux set/get process capabilities
cap_get_file IRIX get or set the capabilities for a pathname
glcenable IRIX enable or disable GLC capabilities
cap_get_fd IRIX get or set the capabilities for an open file
cdk_display NetBSD Curses Development Kit Display Capabilities.
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service