*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> ndir (5)              
Title
Content
Arch
Section
 

Contents


 ndir(5)                                                             ndir(5)




 NAME    [Toc]    [Back]
      ndir.h - format of HP-UX directory streams

 SYNOPSIS    [Toc]    [Back]
      #include <ndir.h>

 DESCRIPTION    [Toc]    [Back]
      This header file defines data types used by the directory stream
      routines described in directory(3C).  It is provided to allow older
      HP-UX programs to compile unmodified.  This file is obsoleted starting
      from HP-UX 10.30 and is going to be removed in future releases. The
      header file <dirent.h> described on dirent(5) should be used in all
      new programs for compatibility with System V Release 3, the X/Open
      Portability Guide, and the IEEE P1003.1 POSIX standard.

      The following data types are defined:

           DIR            A structure containing information about an open
                          directory stream.

           struct direct  A structure defining the format of entries
                          returned by the old HP-UX readdir function (see
                          directory(3C)).

      The struct direct structure includes the following members:

           char d_name[MAXNAMLEN+1];  /* name of directory entry */
           long d_ino;                /* file serial number */
           short d_namlen;            /* length of string in d_name */
           short d_reclen;            /* length of this record */

      The constant MAXNAMLEN is defined in <ndir.h>.

      This file also contains external declarations for the functions in the
      directory(3C) package, including the following declaration:

           extern struct direct *readdir();

 WARNINGS    [Toc]    [Back]
      lint(1) might complain about programs that include this file, although
      they compile and run correctly.

 AUTHOR    [Toc]    [Back]
      ndir.h was developed by the University of California, Berkeley, and
      HP.

 SEE ALSO    [Toc]    [Back]
      directory(3C), dirent(5).


 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
dirent HP-UX format of directory streams and directory entries
dirent FreeBSD directory file format
dir FreeBSD directory file format
dir OpenBSD directory file format
dirent OpenBSD directory file format
getdirentri HP-UX get entries from a directory in a file-systemindependent format
getdirentries Linux get directory entries in a filesystem independent format
getdirentries NetBSD get directory entries in a filesystem independent format
getdents NetBSD get directory entries in a filesystem independent format
getdirentries OpenBSD get directory entries in a filesystem independent format
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service