*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dirent (5)              
Title
Content
Arch
Section
 

Contents


 dirent(5)                                                         dirent(5)




 NAME    [Toc]    [Back]
      dirent.h - format of directory streams and directory entries

 SYNOPSIS    [Toc]    [Back]
      #include <sys/types.h>

      #include <dirent.h>

 DESCRIPTION    [Toc]    [Back]
      This header file defines data types used by the directory stream
      routines described in directory(3C).

      The following data types are defined:

           DIR                 A structure containing information about an
                               open directory stream.

           struct dirent       A structure defining the format of entries
                               returned by the readdir() function (see
                               directory(3C)).

      The struct dirent structure includes the following members:

           char d_name[MAXNAMLEN+1];  /* name of directory entry */
           ino_t d_ino;               /* file serial number */
           short d_namlen;            /* length of string in d_name */
           short d_reclen;            /* length of this record */

      The constant MAXNAMLEN is defined in <dirent.h>.

      Note that the d_reclen entry is used internally to represent the
      offset from the current entry to the next valid entry.  Therefore,
      d_reclen is not the length of the current entry, but the length of the
      current record where a record is an entry plus any currently unused
      space between the current entry and the next valid entry.  The unused
      space between valid dirent entries results from changes in a
      directory's contents, such as the deletion of files and other
      directories.

      This file also contains external declarations for the functions in the
      directory(3C) package.

 WARNINGS    [Toc]    [Back]
      For 32-bit applications, the d_ino field may overflow for filesystems
      that use 64-bit values.  In this case, the most-significant bytes will
      be truncated without error, and the value may not be unique.

 AUTHOR    [Toc]    [Back]
      <dirent.h> was developed by AT&T and HP.





 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 dirent(5)                                                         dirent(5)




 SEE ALSO    [Toc]    [Back]
      directory(3C), ndir(5).

 STANDARDS CONFORMANCE    [Toc]    [Back]
      <dirent.h>: AES, SVID2, SVID3, XPG2, XPG3, XPG4, FIPS 151-2, POSIX.1


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
ndir HP-UX format of HP-UX directory streams
getdirentri HP-UX get entries from a directory in a file-systemindependent format
getdirentries NetBSD get directory entries in a filesystem independent format
getdirentries OpenBSD get directory entries in a filesystem independent format
getdents NetBSD get directory entries in a filesystem independent format
getdirentries Linux get directory entries in a filesystem independent format
getdirentries Tru64 Get directory entries in a file-system independent format.
getdirentries FreeBSD get directory entries in a file system independent format
getdents FreeBSD get directory entries in a file system independent format
getdents IRIX read directory entries and put in a file system independent format
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service