*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> nlist_pa (4)              
Title
Content
Arch
Section
 

Contents


 nlist_pa(4)                                                     nlist_pa(4)
                             For PA-RISC Systems



 NAME    [Toc]    [Back]
      nlist_pa: nlist, nlist64 - nlist and nlist64 structure formats

 SYNOPSIS    [Toc]    [Back]
      #include <nlist.h>

    Remarks    [Toc]    [Back]
      The exact content of the structures defined below can be best found by
      examining /usr/include/nlist.h.  It varies somewhat between various
      HP-UX implementations.

 DESCRIPTION    [Toc]    [Back]
      nlist() and nlist64() can be used to extract information from the
      symbol table in an object file (see nlist(3C)).  They are basically
      the same tool except nlist() can only process SOM files on a PA-RISC
      32-bit system while nlist64() can process SOM and ELF files on either
      a PA-RISC 32-bit or 64-bit system.  Since symbol tables are machine
      dependent (as defined in each implementation's copy of <a.out.h>), a
      header file, nlist.h is defined to encapsulate the differences.

      The nlist function, either nlist() or nlist64(), when used with the
      corresponding nlist structure, can be used to extract certain
      information about selected symbols in the symbol table.  The data
      associated with each symbol is machine specific, thus only the name
      and position of the n_name field in the function is standardized by
      HP-UX.  The rest of the structure includes at least the value and type
      of the symbol.  The names and meanings of all fields not standardized
      will change no more than necessary.

           struct nlist {
               char    *n_name;
               /* other fields as needed;
                  the following are suggested if they apply */
               char           *n_qual;
               unsigned short  n_type;
               unsigned short  n_scope;
               unsigned int    n_info;
               unsigned long   n_value;
           };

           struct nlist64 {
               char    *n_name;
               /* other fields as needed;
                  the following are suggested if they apply */
               char              *n_qual;
               unsigned short     n_type;
               unsigned short     n_scope;
               unsigned long      n_info;
               unsigned long long n_value;
               unsigned int       is_elf:1;
               unsigned int       is_32:1;



 Hewlett-Packard Company            - 1 -      HP-UX 11i Version 2: Sep 2004






 nlist_pa(4)                                                     nlist_pa(4)
                             For PA-RISC Systems



               unsigned int       reserved1:30;
               unsigned long long reserved2;
               unsigned long long reserved3;
           };

 SEE ALSO    [Toc]    [Back]
      nlist(3C), a.out(4).


 Hewlett-Packard Company            - 2 -      HP-UX 11i Version 2: Sep 2004
[ Back ]
      
      
 Similar pages
Name OS Title
ALgetconfig IRIX (obsolete) get/set the ALconfig structure of an audio ALport structure
SSL_CTX_get_cert_store Tru64 Get the X509_STORE structure in the SSL_CTX structure
perlform IRIX Perl formats
nroff Tru64 Formats text
perlform OpenBSD Perl formats
catmsgfmt IRIX Formats an error message
formatRMedia IRIX Formats removable media
strfmon Tru64 Formats monetary strings
intro FreeBSD introduction to file formats
sfconvert Linux convert between various audio formats
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service