nlist_ia(4) nlist_ia(4)
For Itanium(R)-based Systems
NAME [Toc] [Back]
nlist_ia: nlist, nlist64 - nlist and nlist64 structure formats
SYNOPSIS [Toc] [Back]
#include <nlist.h>
Remarks [Toc] [Back]
The exact content of the structure defined below can be best found by
examining /usr/include/nlist.h. It varies somewhat between various
HP-UX implementations.
DESCRIPTION [Toc] [Back]
nlist() and nlist64() can be used to extract information from the
symbol table in an object file (see nlist(3E)). They are basically
the same tool, and both can process SOM and Elf files. Since symbol
tables are machine dependent (as defined in each implementation's copy
of <a.out.h>), a header file, nlist.h is defined to encapsulate the
differences.
The nlist function, either nlist() or nlist64(), when used with the
corresponding nlist structure, can be used to extract certain
information about selected symbols in the symbol table. The data
associated with each symbol is machine specific, thus only the name
and position of the n_name field in the function is standardized by
HP-UX. The rest of the structure includes at least the value and type
of the symbol. The names and meanings of all fields not standardized
will change no more than necessary.
The nlist structure is the same as the nlist64 structure and is used
for source compatibility purposes.
struct nlist64 {
char *n_name;
/* other fields as needed;
the following are suggested if they apply */
char *n_qual;
unsigned short n_type;
unsigned short n_scope;
unsigned long n_info;
unsigned long long n_value;
unsigned int is_elf:1;
unsigned int is_32:1;
unsigned int reserved1:30;
unsigned long long reserved2;
unsigned long long reserved3;
};
SEE ALSO [Toc] [Back]
nlist(3E), a.out(4).
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004 [ Back ] |