*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_log (1m)              
Title
Content
Arch
Section
 

Contents


 log(1m)                  Open Software Foundation                   log(1m)




 NAME    [Toc]    [Back]
      log - A dcecp object that manages serviceability routing and debug
      routing

 SYNOPSIS    [Toc]    [Back]
      log help [operation | -verbose]

      log list {RPC_server_namespace_entry | string_binding_to_server}
      [-comp component_name_list]

      log modify {RPC_server_namespace_entry | string_binding_to_server}
      -change {routing_specifications | debug_routing_specifications}

      log operations

      log show {RPC_server_namespace_entry | string_binding_to_server}
      [-debug]


 ARGUMENTS    [Toc]    [Back]
      RPC_server_namespace_entry
                Specifies the namespace entry of the target server. For
                example, /.:/hosts/host_name/dts-entity is the name of the
                DTS server.

      operation The name of the log operation for which to display help
                information.

      string_binding_to_server
                A remote procedure call (RPC) string binding that describes
                the target server's network location.  The value has the
                form of an RPC string binding, without an object Universal
                Unique Identifier (UUID). The binding information contains
                an RPC protocol, a network address, and an endpoint within
                [] (brackets), in one of the two following forms:

                rpc-prot-seq:network-addr[endpoint]

                object_uuid@rpc-prot-seq:network-addr[endpoint]


 DESCRIPTION    [Toc]    [Back]
      The log object represents the current state of message routing for a
      given server.  It supports routing for both serviceability and debug
      messages.  Debug routing may be removed from production environment
      servers while still being used by application servers.

      The log command works on both local and remote servers. You can
      identify the target server by supplying either the server's entry in
      the namespace or a fully bound string binding.  You can specify
      multiple target servers as a space-separated list.  When specifying



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 log(1m)                  Open Software Foundation                   log(1m)




      multiple servers, you can mix the namespace entry and string binding
      formats in the same list.

 OPERATIONS    [Toc]    [Back]
    log help
      Returns help information about the log object and its operations. The
      syntax is as follows:

      log help [operation | -verbose]


      Options    [Toc]    [Back]

      -verbose  Displays detailed information about the log object.


      Used without an argument or option, the log help command returns brief
      information about each log operation.  The optional operation argument
      is the name of an operation about which you want detailed information.
      Alternatively, you can use the -verbose option for more detailed
      information about the log object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the log help command.

      Examples    [Toc]    [Back]

      dcecp> log help
      list                Returns serviceability components registered by a server.
      modify              Changes serviceability routing specifications of a server.
      show                Returns serviceability routing settings for a server.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    log list
      Returns a list of serviceability components registered by the target
      server.  The syntax is as follows:

      log list {RPC_server_namespace_entry | string_binding_to_server}
      [-comp component_name_list]


      Options    [Toc]    [Back]

      -comp component_name_list
                A list of one or more DCE serviceability component names for
                which associated subcomponents should be returned.




 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 log(1m)                  Open Software Foundation                   log(1m)




      If you specify more than one server, the returned lists for the second
      and subsequent servers are concatenated to the returned list for the
      first server.

      The -comp option specifies a space-separated list of DCE
      serviceability component names. For each named component, the command
      returns a list of the associated subcomponents.  For each subcomponent
      in the list, the command displays its name, its level, and its
      description.  The order of the component names is arbitrary.  If you
      specify more than one component name, the resulting subcomponent lists
      are concatenated.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the log list command.

      Examples    [Toc]    [Back]

      dcecp> log list /.:/hosts/goober/cds-server
      {svc cds dts rpc sec}
      dcecp>

      dcecp> log list /.:/hosts/goober/cds-server -comp dts
      {general  0  "General server administration"}
      {events   0  "Events received and acted upon"}
      {arith    0  "Math operations"}
      {ctlmsgs  0  "Control messages received"}
      {msgs     0  "Messages received"}
      {states   0  "Server state transitions"}
      {threads  0  "Thread interactions"}
      {config   0  "Server/cell configuration"}
      {sync     0  "Server sync interactions"}
      dcecp>


    log modify
      Sets message routing specifications for one or more specified servers.
      The syntax is as follows:

      log modify {RPC_server_namespace_entry | string_binding_to_server}
      -change {routing_specifications | debug_routing_specifications}


      Options    [Toc]    [Back]

      -change   Specifies the routing specifications (serviceability or
                debug) to change.


      The -change option specifies the routing specifications you want to
      change.  There is a fixed, well-known set of routing defaults.  You



 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 log(1m)                  Open Software Foundation                   log(1m)




      can change these defaults, but you cannot add new routings or remove
      existing routings.  Routing is always set on a per-server basis and is
      recorded in the log object for each server. This operation returns an
      empty string on success.

      Serviceability and debug messages can be written to any of the normal
      output destinations.  You can specify routing for serviceability and
      debug messages in any of the following ways:


        +  Through the dcecp log object, if the server supports the remote
           serviceability interface

        +  By the contents of the dce-local-path/svc/routing file

        +  By the contents of an environment variable


      For a complete discussion of the ways in which you can specify
      routings for serviceability and debug messages, refer to the
      svcroute(5) reference page.

      Privileges Required    [Toc]    [Back]

      The privileges are determined by what the server allows for
      permissions.

      Examples    [Toc]    [Back]

      dcecp> log modify /.:/tserver -change {{FATAL TEXTFILE /dev/console} \
      > {ERROR TEXTFILE /tmp/timop_errors.5.100} {NOTICE BINFILE /tmp/timop_log%ld }}
      dcecp>


    log operations
      Returns a list of the operations supported by the log object. The
      syntax is as follows:

      log operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the log operations command.

      Examples    [Toc]    [Back]





 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 log(1m)                  Open Software Foundation                   log(1m)




      dcecp> log operations
      list modify show help operations
      dcecp>


    log show
      Returns a list describing the serviceability routing settings for a
      server.  The syntax is as follows:

      log show {RPC_server_namespace_entry | string_binding_to_server}
      [-debug]


      Options    [Toc]    [Back]

      -debug    Returns debug routing settings rather than serviceability
                routing settings.


      If you specify more than one server, the returned routings for the
      second and subsequent servers are concatenated to the returned
      routings for the first server.  The order of the returned routing
      settings is arbitrary.

      By default the operation returns serviceability routing settings.  Use
      the -debug option to return debug routing settings.  Debug routing
      settings are not available on servers for which debugging has been
      turned off (production servers, for example).

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the log show command.

      Examples    [Toc]    [Back]

      dcecp> log show /.../bigred/hosts/acme/cds-clerk
      {ERROR STDERR -}
      {FATAL FILE /dev/console}
      {WARNING FILE /tmp/warnings.log}
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m)

      Files: svcroute(5).


 Hewlett-Packard Company            - 5 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
routed Tru64 Manages network routing tables
routes Tru64 Specifies Internet routing information to the routing tables
rtquery OpenBSD query routing daemons for their routing tables
rtquery FreeBSD query routing daemons for their routing tables
rtquery IRIX query routing daemons for their routing tables
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_link HP-UX A dcecp object that manages a soft link in CDS
dcecp_server HP-UX A dcecp object that manages DCE application servers
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service