BUS_GENERIC_SHUTDOW... FreeBSD Kernel Developer's ManualBUS_GENERIC_SHUTDOW...
bus_generic_shutdown -- generic implementation of DEVICE_SHUTDOWN for
busses
#include <sys/param.h>
#include <sys/bus.h>
int
bus_generic_shutdown(device_t dev);
This function provides an implementation of the DEVICE_SHUTDOWN(9) method
which can be used by most bus code. It simply calls the
DEVICE_SHUTDOWN(9) method of each child device attached to the bus.
Zero is returned on success, otherwise an appropriate error is returned.
device(9), driver(9)
This man page was written by Doug Rabson.
FreeBSD 5.2.1 June 16, 1998 FreeBSD 5.2.1 [ Back ] |