*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> values (5)              
Title
Content
Arch
Section
 

Contents


 values(5)                                                         values(5)




 NAME    [Toc]    [Back]
      values - machine-dependent values

 SYNOPSIS    [Toc]    [Back]
      #include <values.h>

 DESCRIPTION    [Toc]    [Back]
      This file contains a set of manifest constants, conditionally defined
      for particular processor architectures.

      The model assumed for integers is binary representation (one's or
      two's complement), where the sign is represented by the value of the
      high-order bit.

           BITS(type)     The number of bits in a specified type (e.g.,
                          int).

           HIBITS         The value of a short integer with only the highorder
 bit set (in most implementations, 0x8000).

           HIBITL         The value of a long integer with only the highorder
 bit set (in most implementations,
                          0x80000000).

           HIBITI         The value of a regular integer with only the
                          high-order bit set (usually the same as HIBITS or
                          HIBITL).

           MAXSHORT       The maximum value of a signed short integer (in
                          most implementations, 0x7FFF _ 32767).

           MAXLONG        The maximum value of a signed long integer (in
                          most implementations, 0x7FFFFFFF _ 2147483647).

           MAXINT         The maximum value of a signed regular integer
                          (usually the same as MAXSHORT or MAXLONG).

           MAXFLOAT, LN_MAXFLOAT
                          The maximum value of a single-precision floatingpoint
 number, and its natural logarithm.

           MAXDOUBLE, LN_MAXDOUBLE
                          The maximum value of a double-precision floatingpoint
 number, and its natural logarithm.

           MINFLOAT, LN_MINFLOAT
                          The minimum positive value of a single-precision
                          floating-point number, and its natural logarithm.

           MINDOUBLE, LN_MINDOUBLE
                          The minimum positive value of a double-precision



 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 values(5)                                                         values(5)




                          floating-point number, and its natural logarithm.

           FSIGNIF        The number of significant bits in the mantissa of
                          a single-precision floating-point number.

           DSIGNIF        The number of significant bits in the mantissa of
                          a double-precision floating-point number.

 FILES    [Toc]    [Back]
      /usr/include/values.h

 SEE ALSO    [Toc]    [Back]
      intro(3), math(5).

 STANDARDS CONFORMANCE    [Toc]    [Back]
      <values.h>: XPG2


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
pmap_clear_modify OpenBSD machine dependent interface to the MMU
pmap_growkernel OpenBSD machine dependent interface to the MMU
pmap_enter OpenBSD machine dependent interface to the MMU
pmap_destroy OpenBSD machine dependent interface to the MMU
pmap_create OpenBSD machine dependent interface to the MMU
pmap_copy_page OpenBSD machine dependent interface to the MMU
pmap_clear_reference OpenBSD machine dependent interface to the MMU
pmap_steal_memory OpenBSD machine dependent interface to the MMU
pmap_is_modified OpenBSD machine dependent interface to the MMU
pmap_is_referenced OpenBSD machine dependent interface to the MMU
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service