*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> rcsintro (5)              
Title
Content
Arch
Section
 

Contents


 rcsintro(5)                                                     rcsintro(5)




 NAME    [Toc]    [Back]
      rcsintro - description of RCS commands

 DESCRIPTION    [Toc]    [Back]
      Revision Control System (RCS) automates the storing, retrieval,
      logging, identification, and merging of revisions of ASCII text files.
      RCS is useful for managing files that are revised frequently.

    Functions of RCS    [Toc]    [Back]
      +  Storage and retrieval of revisions of text files.  RCS saves
         revisions in a space efficient way.  Revisions can be retrieved by
         ranges of revision numbers, symbolic names, dates, authors, and
         states.

      +  Maintenance of a complete history of changes.  RCS logs all changes
         automatically.  In addition to the text of each revision, RCS
         stores the author, date and time of check in, and a log message
         summarizing the change.

      +  Resolution of access conflicts.  When two or more people try to
         modify the same revision of a file, RCS alerts them and prevents
         one modification from corrupting the other.

      +  Maintenance of a tree of revisions.  RCS can maintain separate
         lines of development for each file.  It stores a tree structure
         that represents the ancestral relationships among revisions.

      +  Merging of revisions and resolution of conflicts.  Two separate
         lines of development of a file can be coalesced by merging.  If the
         revisions to be merged affect the same lines of a file, RCS flags
         the overlapping changes.

      +  Release and configuration control.  Revisions can be assigned
         symbolic names and marked as released, stable, experimental, etc.
         With these facilities, configurations of a file can be described
         simply and directly.

      +  Automatic identification of each revision with filename, revision
         number, creation time, author, etc.  This identification is like a
         stamp that can be embedded at an appropriate place in the text of a
         revision.  These stamps make it simple to determine which revisions
         of which files make up a given configuration.

      +  Minimization of secondary storage.  RCS uses very little extra
         space for revisions (only the differences are stored).  If
         intermediate revisions are deleted, the remaining deltas are
         compressed accordingly.

    Getting Started with RCS    [Toc]    [Back]
      The basic user interface is extremely simple.  The novice only needs
      to learn two commands: ci(1) and co(1).  ci, short for "check in,"



 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 rcsintro(5)                                                     rcsintro(5)




      deposits the contents of a text file into an archival file called an
      RCS file.  An RCS file contains all revisions of a particular text
      file.  co, short for "check out", retrieves revisions from an RCS
      file.

      Suppose you have a file f.c that you wish to put under control of RCS.
      Invoke the check in command:

           ci f.c

      This command creates the RCS file f.c,v, stores f.c into it as
      revision 1.1, and deletes f.c.  It also asks you for a description.
      The description should be a synopsis of the contents of the file.  All
      subsequent check-in commands will ask for a log entry, which should
      summarize the changes that were made.

      Files with names ending with ",v" are called RCS files ("v" stands for
      "versions"), all other files are presumed to be working files.  To get
      back the working file f.c in the previous example, use the check out
      command:

           co f.c

      This command extracts the latest revision from f.c,v and writes it
      into f.c.  You can now edit f.c and check it back in by invoking:

           ci f.c

      ci increments the revision number properly.  If ci complains with the
      message:

           ci error: no lock set by <your login>

      your system administrator has decided to create all RCS files with the
      locking attribute set to "strict".  In this case, you should have
      locked the revision during the previous check out.  Your last check
      out should have been:

           co -l f.c

      Of course, it is too late now to do the check out with locking,
      because you probably modified f.c already, and a second check out
      would overwrite your modifications.  Instead, invoke:

           rcs -l f.c

      This command will lock the latest revision for you, unless somebody
      else has already locked it.  In that case, you will have to negotiate
      with that person.





 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003






 rcsintro(5)                                                     rcsintro(5)




      Locking assures that you, and only you, can check in the next update,
      and avoids nasty problems if several people work on the same file.
      Even if a revision is locked, it can still be checked out for reading,
      compiling, etc.  All that locking prevents is a check in by anybody
      but the locker.

      If your RCS file is private, i.e., if you are the only person who is
      going to deposit revisions into it, strict locking is not needed and
      you can turn it off.  If strict locking is turned off, the owner of
      the RCS file need not have a lock for check in; all others still do.
      Turning strict locking off and on is done with the commands:

           rcs -U f.c

      and

           rcs -L f.c

      If you do not want to clutter your working directory with RCS files,
      create a subdirectory called RCS in your working directory, and move
      all your RCS files there.  RCS commands will search that directory to
      find needed files.  All the commands discussed above will still work
      without any modification.

      To avoid the deletion of the working file during check in (in case you
      want to continue editing), invoke:

           ci -l f.c

      or

           ci -u f.c

      These commands check in f.c as usual, but perform an implicit check
      out.  The first form also locks the checked in revision, the second
      one does not.  Thus, these options save you one check out operation.
      The first form is useful if locking is strict; the second one if not
      strict.  Both update the identification markers in your working file
      (see below).

      You can give ci the number you want assigned to a checked in revision.
      Assume all your revisions were numbered 1.1, 1.2, 1.3, etc., and you
      would like to start release 2.  The command:

           ci -r2 f.c

      or

           ci -r2.1 f.c





 Hewlett-Packard Company            - 3 -   HP-UX 11i Version 2: August 2003






 rcsintro(5)                                                     rcsintro(5)




      assigns the number 2.1 to the new revision.  From then on, ci will
      number the subsequent revisions with 2.2, 2.3, etc.  The corresponding
      co commands:

           co -r2 f.c

      and

           co -r2.1 f.c

      retrieve the latest revision numbered 2.x and the revision 2.1,
      respectively.  co without a revision number selects the latest
      revision on the "trunk"; i.e., the highest revision with a number
      consisting of 2 fields.  Numbers with more than 2 fields are needed
      for branches.  For example, to start a branch at revision 1.3, invoke:

           ci -r1.3.1 f.c

      This command starts a branch numbered 1 at revision 1.3, and assigns
      the number 1.3.1.1 to the new revision.  For more information about
      branches, see rcsfile(4).

    RCS File Naming and Location    [Toc]    [Back]
      RCS recognizes two kinds of files: RCS files (revision archives), and
      working files.  Working filenames are defined by the RCS user, RCS
      file names are generated by RCS by appending ",v" to the working file
      name.  Pairs of RCS files and working files can be specified in 3
      ways:

           +  Both the RCS file and the working file are given.  The RCS
              filename is of the form path1/workfile,v and the working
              filename is of the form path2/workfile, where path1 and path2
              are (possibly different or empty) paths and workfile is a
              filename.

           +  Only the RCS file is given.  Then the working file is assumed
              to be in the current directory and its name is derived from
              the name of the RCS file by removing path1/ and the suffix
              ",v".

           +  Only the working file is given.  Then the name of the RCS file
              is derived from the name of the working file by removing
              path2/ and appending the suffix ",v".

      If the RCS filename is omitted or specified without a path, RCS
      commands look for the RCS file in the directory ./RCS (or the
      directory it points to if it is a directory link), then in the current
      working directory.

    RCS Directory Links    [Toc]    [Back]
      RCS supports directory links.  If a regular file named RCS exists in



 Hewlett-Packard Company            - 4 -   HP-UX 11i Version 2: August 2003






 rcsintro(5)                                                     rcsintro(5)




      the current working directory, RCS interprets the first line as a path
      name to the directory where RCS files are stored.  RCS can follow a
      chain of up to ten directory links to reach the RCS directory.

    Automatic Identification    [Toc]    [Back]
      RCS can put special strings for identification into your source and
      object code.  To obtain such identification, place the marker:

           $Header$

      into your text, for instance inside a comment.  RCS replaces this
      marker with a string of the form:

           $Header:  filename  revision_number  date  time  author  state$

      With such a marker on the first page of each module, you can always
      see with which revision you are working.  RCS keeps the markers upto-date
 automatically.  To propagate the markers into your object
      code, simply put them into literal character strings.  In C, this is
      done as follows:

           static char rcsid[] = $Header$ ;

      The command ident extracts such markers from any file, even object
      code and dumps.  Thus, ident lets you find out which revisions of
      which modules were used in a given program.

      You may also find it useful to put the marker $Log$ into your text,
      inside a comment.  This marker accumulates the log messages that are
      requested during check in.  Thus, you can maintain the complete
      history of your file directly inside it.  There are several additional
      identification markers.  See co(1) for details.

 WARNINGS    [Toc]    [Back]
      Names of RCS files are generated by appending ,v to the end of the
      working file name.  If the resulting RCS file name is too long for the
      file system on which the RCS file should reside, the RCS command
      terminates with an error message.

      RCS is designed to be used with TEXT files only.  Attempting to use
      RCS with non-text (binary) files will result in data corruption.

 AUTHOR    [Toc]    [Back]
      rcsintro was developed by Walter F. Tichy, Purdue University, West
      Lafayette, IN 47907.
      Revision Number:  3.0; Release Date: 83/05/11.
      Copyright 1982 by Walter F. Tichy.

 SEE ALSO    [Toc]    [Back]
      ci(1), co(1), ident(1), merge(1), rcs(1), rcsdiff(1), rcsmerge(1),
      rlog(1), rcsfile(4).



 Hewlett-Packard Company            - 5 -   HP-UX 11i Version 2: August 2003






 rcsintro(5)                                                     rcsintro(5)




      Walter F. Tichy, "Design, Implementation, and Evaluation of a Revision
      Control System," in Proceedings of the 6th International Conference on
      Software Engineering, IEEE, Tokyo, Sept. 1982.


 Hewlett-Packard Company            - 6 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
queuedefs Tru64 Queue description file for at, batch, and cron commands
captoinfo HP-UX convert a termcap description into a terminfo description
captoinfo Tru64 Converts a termcap description into a terminfo description.
infotocap OpenBSD convert a terminfo description into a termcap description
captoinfo OpenBSD convert a termcap description into a terminfo description
captoinfo IRIX convert a termcap description into a terminfo description
infotocap Linux convert a terminfo description into a termcap description
captoinfo Linux convert a termcap description into a terminfo description
intro IRIX introduction to commands, application programs, and programming commands.
DL_GetDbAcl Tru64 Get ACL description (CDSA)
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service