*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> mknod (5)              
Title
Content
Arch
Section
 

Contents


 mknod(5)                                                           mknod(5)




 NAME    [Toc]    [Back]
      mknod.h - header file of macros for handling device numbers

 SYNOPSIS    [Toc]    [Back]
      #include <sys/mknod.h>

 DESCRIPTION    [Toc]    [Back]
      The header file <sys/mknod.h> defines macros to create and interpret
      device identification numbers for use with the mknod() system call
      (see mknod(2)).

      The use of these macros is architecture-dependent.  See the System
      Administration Manual for your system for information on how to select
      major and minor device numbers.

      mknod.h contains the macro

           dev_t makedev(int major, int minor)

      which packs the major and minor components into a device
      identification number suitable for the dev argument of mknod(), and
      the two macros:

           int major(dev_t dev)
           int minor(dev_t dev)

      which extract the major and minor number components, respectively,
      from a device identification number, dev.

      The macro MINOR_FORMAT is a printf() specification (see printf(3S))
      that prints the minor number in the format best suited to the
      particular implementation; it is used by the long format of the ls
      command (see ls(1)) to show the minor numbers for device files.

      The base of the number is indicated in the same way as in the C
      programming language: no leading zero for decimal, leading zero for
      octal, and leading 0x for hexadecimal.

 SEE ALSO    [Toc]    [Back]
      ls(1), mknod(1M), mknod(2), printf(3S).


 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
c_excpt Tru64 Header file defining structured exception handling keywords, intrinsics, and structures for the C la...
efi_fsinit HP-UX write an EFI file system header on a device file
stdarg HP-UX macros for handling variable argument lists
sat_write_filehdr IRIX write audit file header, write close time to audit file header
AFclosefile IRIX close an audio file, update file header if file was opened for write access.
i4bq921 FreeBSD isdn4bsd pseudo device driver handling the Q.921 protocol
i4bq931 FreeBSD isdn4bsd pseudo device driver handling the Q.931 protocol
ldohseek Tru64 seek to the optional file header of a common object file
ldohseek IRIX seek to the optional file header of a common object file
inet6_opt_init Tru64 Return the length of an IPv6 extension header with no options and initialize the header
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service