*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> complex (5)              
Title
Content
Arch
Section
 

Contents


 complex(5)                                                       complex(5)
                        Itanium(R)-based System Only



 NAME    [Toc]    [Back]
      complex - complex functions and macros

 SYNOPSIS    [Toc]    [Back]
      #include <complex.h>

 DESCRIPTION    [Toc]    [Back]
      This file contains declarations of all the functions in the Complex
      Library (described in Section (3M)).

      It defines the types

           extended       The Itanium-based system 80-bit double-extended
                          type.

           quad           An IEEE 754-compliant, 128-bit floating-point
                          type.  On HP-UX, quad is a synonym for long
                          double.

      It defines the macros

           complex        Expands to _Complex, a keyword designating complex
                          types.

           imaginary      Expands to _Imaginary, a keyword designating
                          imaginary types.

      These macros and the names of the real types, in combination, provide
      designations for the complex and imaginary types

           float complex
           double complex
           long double complex
           extended complex
           quad complex
           float imaginary
           double imaginary
           long double imaginary
           extended imaginary
           quad imaginary

      This file also defines the macros

           _Imaginary_I      Expands to a constant expression of type const
                             float imaginary, with the value of the
                             imaginary unit (a number whose square is -1).

           _Complex_I        Expands to a constant expression of type const
                             float complex, with the value of the imaginary
                             unit.




 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 complex(5)                                                       complex(5)
                        Itanium(R)-based System Only



           I                 Expands to _Imaginary_I.  It can be used to
                             efficiently construct complex expressions in
                             the style x + y*I, where x and y are real.

      This header is for Itanium-based systems only.  To use it, compile
      with the default -Ae option.  To use the types extended complex, quad
      complex, extended imaginary, or quad imaginary, compile with the
      -fpwidetypes option.

 FILES    [Toc]    [Back]
      /usr/include/complex.h

 SEE ALSO    [Toc]    [Back]
      intro(3), fenv(5), math(5).

 STANDARDS CONFORMANCE    [Toc]    [Back]
      <complex.h> : ISO/IEC C99 (including Annex G, ``IEC 60559-compatible
      complex arithmetic'')


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
fenv HP-UX floating-point environment macros and functions
mbuf NetBSD functions and macros for managing memory used by networking code
m_gethdr NetBSD functions and macros for managing memory used by networking code
m_devget NetBSD functions and macros for managing memory used by networking code
m_copym NetBSD functions and macros for managing memory used by networking code
m_copypacket NetBSD functions and macros for managing memory used by networking code
m_copydata NetBSD functions and macros for managing memory used by networking code
m_copyback NetBSD functions and macros for managing memory used by networking code
m_cat NetBSD functions and macros for managing memory used by networking code
m_dup NetBSD functions and macros for managing memory used by networking code
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service