wtmps(4) wtmps(4)
NAME [Toc] [Back]
wtmps, btmps - user login information
SYNOPSIS [Toc] [Back]
#include <sys/types.h>
#include <utmps.h>
DESCRIPTION [Toc] [Back]
wtmps and btmps hold user and accounting information for such commands
as last, who, write, and login (see last(1), who(1), write(1), and
login(1)).
File btmps contains bad login entries for each invalid logon attempt.
File wtmps contains a record for all logins and logouts apart from
accounting records. These files contain utmps-like structure, the key
elements of the structure are given below:
char ut_user[] User login name
char ut_id[] Unique Id to distinguish an entry
char ut_line[] Device name
pid_t ut_pid Process Id
short ut_type Type of Entry
struct ut_exit The exit status of a process
struct timeval ut_tv Time entry was made
char ut_host[] Host name, if remote
uint8_t ut_addr[] Internet Address of the Host,
if remote
short ut_addr_type Flag to identify type of address
in ut_addr
#define WTMPS_FILE "/var/adm/wtmps"
#define BTMPS_FILE "/var/adm/btmps"
Note that wtmps and btmps tend to grow without bound, and should be
checked regularly. Information that is no longer useful should be
removed periodically to prevent the file from becoming too large.
Also note that wtmps and btmps are not created by the programs that
maintain them. Thus, if these files are removed, login record-keeping
is turned off.
AUTHOR [Toc] [Back]
wtmps and btmps were developed by Hewlett-Packard Company.
FILES [Toc] [Back]
/var/adm/wtmps
/var/adm/btmps
SEE ALSO [Toc] [Back]
last(1), login(1), who(1), write(1), acctcon(1M), fwtmp(1M),
wtmpfix(1M), getuts(3C).
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003 [ Back ] |