*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> utmp (4)              
Title
Content
Arch
Section
 

Contents


 utmp(4)                                                             utmp(4)
                               TO BE OBSOLETED



 NAME    [Toc]    [Back]
      utmp, wtmp, btmp - utmp, wtmp, btmp entry format

 SYNOPSIS    [Toc]    [Back]
      #include <sys/types.h>
      #include <utmp.h>

 DESCRIPTION    [Toc]    [Back]
      These files, which hold user and accounting information for such
      commands as last, who, write, and login (see last(1), who(1),
      write(1), and login(1)), have the following structure as defined by
      <utmp.h>:

         #define UTMP_FILE   "/etc/utmp"
         #define WTMP_FILE   "/var/adm/wtmp"
         #define BTMP_FILE   "/var/adm/btmp"
         #define ut_name     ut_user

         struct  utmp {
           char   ut_user[8];           /* User login name */
           char   ut_id[4];             /* /etc/inittab id(usually line#)*/
           char   ut_line[12]           /* device name (console, lnxx) */
           pid_t  ut_pid;               /* process id */
           short  ut_type;              /* type of entry */
           struct exit_status
               short  e_termination;    /* Process termination status*/
               short  e_exit;           /* Process exit status*/
               } ut_exit;               /* The exit status of a process*/
                                        /* marked as DEAD_PROCESS.*/
           unsigned short ut_reserved1; /* Reserved for future use*/
           time_t  ut_time;             /* time entry was made*/
           char    ut_host[16];         /* host name,if remote*/
           unsigned long ut_addr;       /* host Internet addr, if remote*/
         };

         /*  Definitions for ut_type  */
         #define EMPTY           0
         #define RUN_LVL         1
         #define BOOT_TIME       2
         #define OLD_TIME        3
         #define NEW_TIME        4
         #define INIT_PROCESS    5      /* Process spawned by "init" */
         #define LOGIN_PROCESS   6      /* getty process awaiting login */
         #define USER_PROCESS    7      /* A user process */
         #define DEAD_PROCESS    8
         #define ACCOUNTING      9
         #define UTMAXTYPE       ACCOUNTING  /* Max. legal value of ut_type */

         /*  Special strings or formats used in the "ut_line" field */
         /*  when  accounting for something other than a process  */
         /*  No string for the ut_line field can be more than */



 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 utmp(4)                                                             utmp(4)
                               TO BE OBSOLETED



         /*  11 chars + a NULL in length  */
         #define RUNLVL_MSG      "run-level %c"
         #define BOOT_MSG        "system boot"
         #define OTIME_MSG       "old time"
         #define NTIME_MSG       "new time"

      File utmp contains a record of all users logged onto the system.  File
      btmp contains bad login entries for each invalid logon attempt.  File
      wtmp contains a record of all logins and logouts.

      Note that wtmp and btmp tend to grow without bound, and should be
      checked regularly.  Information that is no longer useful should be
      removed periodically to prevent it from becoming too large.  Also note
      that wtmp and btmp are not created by the programs that maintain them.
      Thus, if these files are removed, record-keeping is turned off.

 FILES    [Toc]    [Back]
      /etc/utmp
      /var/adm/wtmp
      /var/adm/btmp

 AUTHOR    [Toc]    [Back]
      utmp, wtmp, and btmp were developed by HP and the University of
      California, Berkeley.

 SEE ALSO    [Toc]    [Back]
      last(1), login(1), who(1), write(1), acctcon(1M), fwtmp(1M),
      utmpd(1M), getut(3C), getuts(3C), getutx(3C).

 STANDARDS CONFORMANCE    [Toc]    [Back]
      <utmp.h>: XPG2


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
utmp IRIX utmp and wtmp entry formats
utmpx IRIX utmp and wtmp extended-format entries
login FreeBSD log a new login record to the utmp and wtmp files
updwtmp Linux append an entry to the wtmp file
logout FreeBSD remove an entry from the utmp file
ioconfig HP-UX ioconfig entry format
logwtmp FreeBSD append a new record to the wtmp file
rpccp_add_member HP-UX Adds a member to a group in a name service entry; if the specified entry does not exist, creates the entry
rpccp_add_element HP-UX Adds an element to a profile in a name service entry; if the specified entry does not exist, creates the entry
getutline Tru64 Access utmp file entries
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service