*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> set (1m)              
Title
Content
Arch
Section
 

Contents


 set(1m)                  Open Software Foundation                   set(1m)




 NAME    [Toc]    [Back]
      set - Modifies characteristics for the DTS entity.

 SYNOPSIS    [Toc]    [Back]
      dtscp set characteristic


 ARGUMENTS    [Toc]    [Back]
      characteristic
                The name and value of one or more characteristics to be
                modified.  Valid values for characteristic are described in
                the following list.  These values are described in more
                detail in the description section.


                  +  check interval [relative-time]

                  +  courier role [role]

                  +  error tolerance [relative-time]

                  +  global set timeout [relative-time]

                  +  local set timeout [relative-time]

                  +  maximum inaccuracy [relative-time]

                  +  query attempts [integer]

                  +  server entry name [name]

                  +  server group name [name]

                  +  server principal name [name]

                  +  servers required [integer]

                  +  synchronization hold down [relative-time]


 DESCRIPTION    [Toc]    [Back]
      The set command modifies the charactistics you specify for the DTS
      entity. The modifiable characteristics and their values are described
      in the following list.


      check interval [relative-time]

                Specifies the amount of time between checks for faulty
                servers. Applicable only for servers that have external time
                providers.



 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 set(1m)                  Open Software Foundation                   set(1m)




                Default: 0-01:30:00.000
                Value: 0-00:00:30.000 - 10675199-02:48:05.000

      courier role [role]

                Specifies a server's interaction with the set of global
                servers.

                Default: backup courier

                The following values are valid:


                backup courier
                          The local server becomes a courier if none are
                          available on the LAN.

                courier   The local server synchronizes with the global set
                          of servers.

                noncourier
                          The local server does not synchronize with the
                          global set of servers.


      error tolerance [relative-time]

                Specifies the maximum separation allowed between the local
                clock and the computed time before synchronizations become
                abrupt rather than gradual (monotonic).

                Default: 0-00:10:00.000
                Value: 0-00:00:00.500 - 10675199-02:48:05.000

      global set timeout [relative-time]

                Specifies the amount of time the node waits for a response
                to a global synchronization request before sending another
                request or declaring a global server to be unavailable. The
                number of attempts made to reach the server is controlled by
                the query attemps characteristic.

                Default: 0-00:00:15.000
                Value: 0-00:00:00.000 - 0-00:10:00.000

      local set timeout [relative-time]

                Specifies the amount of time the node waits for a response
                to a local synchronization request before sending another
                request or declaring a server to be unavailable. The number
                of attempts made to reach the server is controlled by the



 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 set(1m)                  Open Software Foundation                   set(1m)




                query attemps characteristic.

                Note that the local set timeout value controls only the
                initial contact with a time provider.  During this initial
                contact, the time provider itself determines the timeout
                value for actually reporting back times.  This allows a time
                provider attached to a slow source like a modem to request
                that dtsd wait for a longer interval.

                Default: 0-00:00:05.000
                Value: 0-00:00:00.000 - 0-00:01:00.000

      maximum inaccuracy [relative-time]

                Specifies the inaccuracy limit for the node. When the node
                exceeds the maximum inaccuracy setting, it attempts to
                synchronize.

                Default: 0-00:00:00.100
                Value: 0-00:00:00.000 - 10675199-02:48:05.000

      query attempts [integer]

                Specifies the number of attempts that a node makes to
                contact a server before the node considers the server
                unavailable.

                Default: 3
                Value: 1-10

      server entry name [name]

                Specifies a server's CDS entry name; hostname represents the
                name of the system or node that is the server's client. The
                default setting is the recommended value.

                Default: /.:/hosts/hostname/dts-entity

      server group name [name]

                Specifies the name of the security group that DTS uses for
                authentication checks. DTS clerks and servers do not accept
                time values from DTS servers that are not included in this
                group.

      server principal name [name]

                Specifies a server's principal name for authentication
                purposes; hostname represents the name of the system or node
                that is the server's client. The default setting is the
                recommended value.



 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 set(1m)                  Open Software Foundation                   set(1m)




                Default: /.:/hosts/hostname/self

      servers required [integer]

                Specifies the minimum number of servers required for a
                synchronization.  Settings of 1 or 2 may cause unreliable
                computed times.

                Default: 1 (clerks) 3 (servers)
                Value: 1-10

      synchronization hold down [relative-time]

                Specifies the interval a node must wait to synchronize. Also
                specifies synchronization frequency when a node reaches the
                value specified by the maximum inaccuracy characteristic.

                Clerks:
                Default: 0-00:10:00.000
                Value: 0-00:00:30.000 - 01-00:00:00.000

                Servers:
                Default: 0-00:02:00.000
                Value: 0-00:00:30.000 - 01-00:00:00.000


    Privilege Required    [Toc]    [Back]
      You must have write permission on the ACL associated with the DTS
      entity in order to execute the command.

 NOTES    [Toc]    [Back]
      This command is replaced at Revision 1.1 by the dcecp command and may
      not be provided in future releases of DCE.

      The following two commands are obsolete.  Use the replacements shown.


      set lan timeout
                This command is the same as set local set timeout.

      set wan timeout
                This command is the same as set global set timeout.


 EXAMPLES    [Toc]    [Back]
       1.  The following example command sets the check interval
           characteristic to 30 seconds:


           tscp> set check interval 00-00:00:30.000




 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 set(1m)                  Open Software Foundation                   set(1m)




       2.  The following example shows how to set the number of servers
           required before the entity can synchronize:


           tscp> set servers required 4


       3.  The following example shows how to set the courier role for a
           server:


           tscp> set courier role backup courier


       4.  The following example command sets the error tolerance
           characteristic to seven minutes:


           tscp> set error tolerance 0-00:07:00.000


       5.  The following example command the global set timeout
           characteristic to 45 seconds:


           tscp> set global set timeout 0-00:00:45.000


       6.  The following example command the local set timeout
           characteristic to five seconds:


           tscp> set local set timeout 0-00:00:05.000


       7.  The following example command sets the maximum inaccuracy
           characteristic to three milliseconds:


           tscp> set maximum inaccuracy 0-00:00:00.300


       8.  The following example command sets the server entry name
           characteristic to /.:/hosts/orion/dts-entity:


           tscp> set server entry name /.:/hosts/orion/dts-entity


       9.  The following example command sets the server principal name
           characteristic to /.:/hosts/vega/dts-entity:



 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 set(1m)                  Open Software Foundation                   set(1m)




           tscp> set server principal name /.:/hosts/vega/dts-entity


       10. The following example command sets the synchronization hold down
           characteristic to 15 minutes:


           tscp> set synchronization hold down 0-00:15:00.000


 RELATED INFORMATION    [Toc]    [Back]
      Commands: show (1m)


 Hewlett-Packard Company            - 6 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
delete HP-UX Deletes the DCE DTS entity
nbpremove IRIX unregister an entity name
create HP-UX Creates the DCE DTS entity on the specified node
enable HP-UX Starts the DTS entity on the local node.
disable HP-UX Stops the DCE DTS entity on the local node
show HP-UX Displays current information about the DTS entity
synchronize HP-UX Causes the DTS entity to synchronize the clock on the system where the command is entered.
sia_make_entity_pwd Tru64 Make entity password - SIA (Security Integration Architecture)
signal Tru64 Modifies signal functions
gencat Tru64 Creates and modifies a message catalog
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service