DEVICE_PROBE_AND_AT... FreeBSD Kernel Developer's ManualDEVICE_PROBE_AND_AT...
device_probe_and_attach -- initialise a device
#include <sys/param.h>
#include <sys/bus.h>
int
device_probe_and_attach(device_t dev);
This function is called during autoconfiguration to initialise the
devices in the system. For each device, the DEVICE_PROBE(9) method of
each suitable driver is called and if a probe succeeds, a description of
the device is printed and the DEVICE_ATTACH(9) method is called. If the
device is disabled using device_disable(9) then it will not be probed.
Zero is returned on success, otherwise an appropriate error is returned.
device(9), driver(9)
This manual page was written by Doug Rabson.
FreeBSD 5.2.1 June 16, 1998 FreeBSD 5.2.1 [ Back ] |