parcreate(1M) parcreate(1M)
NAME [Toc] [Back]
parcreate - create a new partition
SYNOPSIS [Toc] [Back]
parcreate
-c cell:[celltype]:[use_on_next_boot]:[failure_usage][:clm_value]
[-c...] [-b path] [-t path] [-s path] [-r cell] [-r...]
[-k s_lock] [-B] [-I IPaddress] [-L clm_value] [-P PartitionName]
[ -u username:[passwd] -h IPaddress|hostname
| -g [passwd] -h IPaddress|hostname]
DESCRIPTION [Toc] [Back]
The parcreate command creates a new partition. By default the new
partition is created on the local complex. Either the -u or the -g
option can be specified to create a partition on the specified target
(local or remote) complex. The command takes the specified cells (and
any attached I/O chassis) and assigns them to the new partition. At
least one of the cells specified must be attached to an I/O chassis
that contains core I/O. The command finds an available partition ID
and assigns it to the new partition. It displays the partition ID of
the newly created partition on stdout.
By the nature of its operation, this command modifies the
configuration of its target complex. Operation can be affected by the
state of the target complex's nPartition Configuration Privilege. If
the nPartition Configuration Privilege is unrestricted (the default),
or the complex is accessed using the -g option, creation of new
partitions is allowed. Otherwise the command fails. The -g option is
unaffected by the state of the nPartition Configuration Privilege.
Note: The state of the nPartition Configuration Privilege can only be
changed at the service processor's Command menu.
Root permission is required to run this command on the local
partition. If the -u or -g option is used to access a remote
partition or complex, root permission is not required on the local
system, and the local system need not exist on an nPartition. If the
-u option is specified, username on the remote host must have root
permission or the command will fail.
Please refer to the HP System Partitions Guide for a description of
the partition management terms used in this man page.
Options and Arguments [Toc] [Back]
parcreate recognizes the following command line options and arguments:
-c cell:[celltype]:[use_on_next_boot]:[failure_usage][:clm_value]
Identifies a cell to be assigned to the partition.
To assign multiple cells to the partition,
multiple -c options should be used.
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
cell specifies the cell ID. It can be specified
either in the local (cabinet#/slot#) or global
(cell#) format. For example, the cell located in
cabinet 0, slot 1 is identified in the local
format as 0/1 or in the global format as 1.
celltype specifies the type of the cell. The
valid celltype value for cells is:
base This is the default if celltype is not
specified.
use_on_next_boot specifies whether the cell will
participate in a reboot. The valid values for
use_on_next_boot are:
y participate in reboot. This is the
default. However if the slot is missing
or the cell does not exist or the cell is
powered off then it defaults to n.
n do not participate in reboot.
At least one of the cells specified using the -c
option must contain core I/O with the
use_on_next_boot flag set to y.
failure_usage field is used by system firmware
when a partition is booted. If a CPU selftest
failure or a DIMM de-allocation occurs during the
power-on self-test process, then this flag is used
by the system firmware to determine whether or not
and how the cell should be integrated into the
partition at boot time. The valid failure_usage
value for cells is:
ri reactivate with memory interleave.
Specifies to integrate the cell as it
would normally be integrated. This is the
default.
clm_value specifies the amount of the memory that
will be configured as local (non-interleaved)
memory for the cell. The clm_value specified
using the -c option takes precedence over the
clm_value specified using the -L option. The
command will issue a warning if the specified
clm_value exceeds the total memory of the cell.
If no clm_value is specified, maximum interleaved
memory (no CLM) is assumed for cells. The command
will issue a warning if 100% CLM is specified for
all the cells in the partition. The clm_value can
be expressed in two forms:
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
+ As a percentage (ratio). The percent number
can be any number in the range 0 - 100 with a
suffix of "%". This number will be rounded up
to 12.5%, 25%, 37.5%, 50%, 62.5%, 75%, 87% or
100%. If the cell contains less than 4GB
memory, then the percentage will be rounded to
25%, 50%, 75% or 100%. The specified
percentage is applied each time the partition
boots, thus resulting in a different value if
the working memory in the cell is different.
For example, a cell in a partition has 8GB
memory and the user specifies 50% CLM. When
the partition boots 4GB of that cell's memory
will be used as CLM. Later the user shuts down
the partition, adds another 8GB memory to that
cell. When the partition is booted again, the
cell now has 16GB of memory, so 8GB (50%) is
allocated as CLM.
+ As an absolute number(default). This can also
be optionally suffixed by "GB". The clm_value
is interpreted as an absolute number of
gigabytes of memory. Numbers other than
integers and halves are rounded up to the
nearest 0.5GB. For example: 2.5GB will not be
rounded up. However 2.3GB will be rounded up
to 2.5GB. For example, a cell in a partition
has 8GB memory and the user specifies 4GB CLM.
When the partition boots 4GB of that cell's
memory will be used as CLM. Later the user
shuts down the partition, adds another 8GB
memory to that cell. When the partition is
booted again, the cell now has 16GB of memory,
but the CLM is still 4GB.
-u username:[passwd]
Specifies the required authorization to access a
partition other than the local system (but can
also be used as a loopback access to the local
partition).
The -h option is required if this option is used.
username specifies a configured user name on the
target partition.
passwd specifies the password associated with the
username. If this field is empty, the command
prompts for the password.
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
Note: This command is a Web-Based Enterprise
Management (WBEM) Client Application. The -u
option accesses the target partition using a
Secure Sockets Layer (SSL) connection. If errors
are reported, check that the conditions described
in the DEPENDENCIES section are satisfied.
SECURITY WARNING: Specifying the password directly
on the command line may pose a security risk in
your environment. The ps(1) or other related
commands can be invoked in such a way as to
display the command line of a process. In this
situation, any authenticated user on the system
can potentially see the password while the process
is executing. Hence, it is highly recommended not
to specify the password on the command line, and
instead allow the command to prompt for the
password.
-h IPaddress|hostname
This option should only be used in combination
with either the -u or -g option.
IPaddress|hostname specifies the IP address or
hostname of the target partition (-u) or complex
(-g).
-g [passwd] Allows access to the complex specified by the -h
option. The accessed complex is then considered
the target complex. Access is via the service
processor's LAN port.
The -h option is required if this option is used.
passwd specifies the IPMI password of the service
processor. If this field is omitted, the command
prompts for the password.
If an error is reported when you attempt to
connect using this option, check to see that IPMI
LAN access has not been disabled on the remote
service processor. Access to the complex via IPMI
over LAN can be enabled or disabled by logging on
to the service processor and using the SA command
from the Command Menu.
The -u and -g options are mutually exclusive.
SECURITY WARNING: Specifying the password directly
on the command line may pose a security risk in
your environment. The ps(1) or other related
commands can be invoked in such a way as to
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
display the command line of a process. In this
situation, any authenticated user on the system
can potentially see the password while the process
is executing. Hence, it is highly recommended not
to specify the password on the command line, and
instead allow the command to prompt for the
password.
-b path Specifies the primary boot path. path specifies a
physical hardware path. Note: On Itanium-based
platforms, boot paths cannot be set or modified on
a non-local partition. You must use the SP
console interface to set any boot path of the
newly created partition.
-t path Specifies the alternate boot path. path specifies
a physical hardware path. Note: On Itanium-based
platforms, boot paths cannot be set or modified on
a non-local partition. You must use the SP
console interface to set any boot path of the
newly created partition.
-s path Specifies the secondary boot path. path specifies
a physical hardware path. Note: On Itanium-based
platforms, boot paths cannot be set or modified on
a non-local partition. You must use the SP
console interface to set any boot path of the
newly created partition.
-r cell Specifies the core cell choices. A core cell
choice is a configured cell which has attached
core IO. If the core cell of a partition is
deleted then the firmware will select the first
core cell choice as the next core cell. One to
four core cell choices can be specified. The
first cell specified is the first core cell
choice, the second cell specified is the second
core cell choice, the third cell specified is the
third core cell choice and the fourth cell
specified is the fourth core cell choice.
A cell can be specified either in the local
(cabinet#/slot#) or global (cell#) format. For
example, the cell located in cabinet 0, slot 1 is
identified in the local format as 0/1 or in the
global format as 1.
-k s_lock Specifies a lock key for the Stable Complex
Configuration Data provided by parmgr. Note: The
-k option is intended for use by system management
tools which invoke the parcreate command
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
programmatically. Command line users should avoid
this option.
-B Specifies that the new partition be booted. The
default is not to boot. Note: On Itanium-based
platforms this option has no effect, because boot
paths cannot be set on the new partition.
Therefore, the partition cannot boot
automatically. You must manually boot up the
partition from the BCH prompt.
-I IPaddress Specifies the IP address that should be used by
management tools such as parmgr to address this
partition. This value must be consistent with the
IP address that is assigned to the partition once
HP-UX is installed and networking is configured.
-L clm_value Specifies the amount of the memory that will be
used as local (non-interleave) memory per cell.
The clm_value specified using the -c option takes
precedence over the clm_value specified using the
-L option. Please refer to the explanation of the
-c option for details of the clm_value formats.
-P PartitionName Specifies the name of the new partition. The
characters which can appear in a valid partition
name are a-z, A-Z, 0-9, - (dash), _ (underscore),
" " (space) and . (period). If the partition
name includes space then the name should be
enclosed within double quotes. The partition name
can have a maxmimum of 64 characters.
Mapping of Global Cell Numbers to Local Cell Numbers [Toc] [Back]
The cabinets in a complex are numbered starting from 0. The cell
slots in each cabinet are also numbered starting from 0. Each cabinet
can have a maximum of 8 cells. For example, the cells located in
cabinet 0 will have the following cell numbers in global format: 0, 1,
2, 3, 4, 5, 6, 7. The cell numbers in corresponding local format will
be 0/0, 0/1, 0/2, 0/3, 0/4, 0/5, 0/6, 0/7.
Similarly the cells located in cabinet 1 will have the following cell
numbers in global format: 8, 9, 10, 11, 12, 13, 14, 15. The cell
numbers in corresponding local format will be 1/0, 1/1, 1/2, 1/3, 1/4,
1/5, 1/6, 1/7.
From the above convention the cell located in cabinet 1, slot 0 is
identified in the local format as 1/0 or in the global format as 8.
The parstatus(1) command will display the above cell as "cab1,cell0".
The cell located in cabinet 1, slot 4 is identified in the local
format as 1/4 or in the global format as 12. The parstatus(1) command
will display the above cell as "cab1,cell4".
Hewlett-Packard Company - 6 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
RETURN VALUE [Toc] [Back]
The parcreate command exits with one of the following values:
0 Successful completion.
1 Error condition occurred.
EXAMPLES [Toc] [Back]
Create a new partition myPartition with two cells. One of the cells is
located in cabinet 0, slot 4. The celltype for the cell is base. The
failure_usage policy for this cell is ri. The CLM value for this cell
is 1GB.
The other cell is located in cabinet 0, slot 6. The celltype and
failure_usage are not specified for this cell. The use_on_next_boot
for both cells is y.
parcreate -P myPartition -c 0/4:base:y:ri:1GB
-c 6::y: -b 0/0/1/2.6 -t 0/0/1/3.6
-s 0/0/1/4.6 -r 0/4
Create a new partition nextPartition with two cells. The cells are
located in cabinet 0, slot 0 and slot 1. This example uses the
default values for the cells. The default celltype will be base.
The default failure_usage policy will be ri. The default
use_on_next_boot will be y. By default there will be no CLM for the
cells.
parcreate -P nextPartition -c 0::: -c 0/1:::
WARNINGS [Toc] [Back]
Activation of iCOD components (cells and CPUs) is possible via this
command. This may result in the requirement to purchase such
components to stay in compliance with a customer's iCOD contract.
DEPENDENCIES [Toc] [Back]
This command uses the Web-Based Enterprise Management (WBEM) product
and certain of its configuration settings. If you encounter
connection errors when using the -u option, check that the following
two conditions are satisfied:
+ Use the cimconfig(1M) command to verify (and correct if necessary)
the setting of the following two variables:
+ enableRemotePrivilegedUserAccess=true
+ enableHttpsConnection=true
+ You must have appended the target partition's digital certificate
to the local partition's Trust Store file. For the nPartition
commands, the Trust Store file is /var/opt/wbem/client.pem.
Hewlett-Packard Company - 7 - HP-UX 11i Version 2: Sep 2004
parcreate(1M) parcreate(1M)
Note: You must have appended the target partition's digital
certificate to the local partition's Trust Store file. For the
npartition commands, the Trust Store file is
/var/opt/wbem/client.pem. This file is used by the commands that
come with WBEM installation. Hence, if the commands that come with
the WBEM installation trust a target partition, then npartition
commands will also trust the target partition.
Refer to the WBEM documents specified in the SEE ALSO section below
for further information.
AUTHOR [Toc] [Back]
parcreate was developed by the Hewlett-Packard Company.
SEE ALSO [Toc] [Back]
cplxmodify(1M), fruled(1), frupower(1M), parmgr(1M), parmodify(1M),
parremove(1M), parstatus(1), parunlock(1M), partition(5),
HP System Partitions Guide on docs.hp.com,
HP WBEM Services for HP-UX System Administrator's Guide on
docs.hp.com,
HP WBEM Services for HP-UX 11i v2.0 on Integrity Servers Version
A.01.05 Release Notes on docs.hp.com.
Hewlett-Packard Company - 8 - HP-UX 11i Version 2: Sep 2004 [ Back ] |