format(1M) format(1M)
NAME [Toc] [Back]
format - format an HP SCSI disk array LUN
SYNOPSIS [Toc] [Back]
format device_file
DESCRIPTION [Toc] [Back]
format formats one LUN of the HP SCSI disk array associated with
device file, device_file. The format will usually be a soft or
zeroing format, in which the controller writes zeroes to the data area
and parity area, if any, of the LUN.
NOTE: The above should always be true of a sub-LUN, but the controller
might decide, based on certain conditions, to do a full format of
a regular LUN, which consists of sending a mode select and a
media initialization command to the physical drive(s) in
question, followed by zeroing the data and parity area, if any.
The conditions which will cause a full format to be done are as
follows:
1. The controller received a Mode Select command which requires
a drive sector size change.
2. The controller received a Mode Select command which changed
a parameter in the Format Device Page (0x03).
3. The LUN contains one or more failed drives. In this case
only a certain subset of the drives containing the failed
drives will be formatted.
4. Either the FmtData or the CmpLst bit in the Format Unit CDB
is set.
RETURN VALUE [Toc] [Back]
format returns the following values:
0 Successful completion.
-1 Command failed.
DIAGNOSTICS AND ERRORS [Toc] [Back]
Errors can originate from problems with:
+ format
+ SCSI (device level) communications
+ system calls
Error messages generated by format:
usage: format <special>
An error in command syntax has occurred. Enter command again
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
format(1M) format(1M)
with all required arguments, in the order shown.
format: device busy
To ensure that format does not modify a disk array that is being
used by another process, format attempts to obtain exclusive
access to the disk array. If the disk array is already opened by
another process (for example, LVM - the Logical Volume Manager),
a "device busy" error message is returned by the driver. To
eliminate the "device busy" condition, determine what process has
the device open. In the case of LVM, it is necessary to
deactivate the volume group containing the array before
formatting array LUNs (see vgchange(1M)).
format: LUN # too big
The LUN number, which is derived from the device file name, is
out of range.
format: LUN does not exist
The addressed LUN is not configured, and thus is not known to the
array controller.
format: Not a raw file
Utilities must be able to open the device file for raw access.
format: Not an HP SCSI disk array
The device being addressed is not an HP SCSI disk array.
SCSI (device level) communication errors:
Sense data associated with the failed operation is printed.
Error messages generated by system calls:
format uses the following system calls:
malloc(), free(), stat(), open(), close(), read(), write(), and
ioctl().
Documentation for these HP-UX system calls contains information about
the specific error conditions associated with each call. format does
not alter the value of errno. The interpretation of errno for
printing purposes is performed by the system utility strerror().
EXAMPLES [Toc] [Back]
To format the HP SCSI disk array LUN /dev/rdsk/c2t0d0 on a Series 800:
format /dev/rdsk/c2t0d0
WARNING [Toc] [Back]
The format command will destroy all user data on the addressed LUN.
DEPENDENCIES [Toc] [Back]
The HP C2425 and HP C2427 disk arrays are only supported on Series 700
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
format(1M) format(1M)
systems running HP-UX version 9.0X.
The HP C2430 disk array is supported on Series 700 and 800 systems
running HP-UX versions 9.0X and 10.0X.
AUTHOR [Toc] [Back]
format was developed by HP.
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003 [ Back ] |