amcfg(1M) amcfg(1M)
NAME [Toc] [Back]
amcfg - manages LUN (logical drive) configuration on the disk array
SYNOPSIS [Toc] [Back]
amcfg -L cntrlrID:LUN -d channel:ID,channel:ID,...
{-r RAIDlevel [-c capacity] [-s SegmentSize] [-force]}
[-V] [-?] ArrayID
amcfg -R cntrlrID:LUN -d channel:ID,channel:ID,...
{-r RAIDlevel [-c capacity] [-s SegmentSize] [-force]}
[-V] [-?] ArrayID
amcfg -C -d channel:ID,channel:ID,... {-r RAIDlevel [-s SegmentSize]}
[-V] [-?] ArrayID
amcfg -D LUN [-V] [-?] ArrayID
amcfg -M LUN -c cntrlrID [-V] [-?] ArrayID
DESCRIPTION [Toc] [Back]
amcfg manages the LUN configuration on the disk array identified by
ArrayID. This involves creating, deleting, replacing, and assigning
ownership of all LUNS on the disk array.
WARNING: Deleting a LUN will destroy all the data on the LUN. Backup
all vital data before deleting a LUN.
The ArrayID used to address the disk array can be the disk array
serial number or name, if one has been assigned to the disk array.
Identifying Disk Modules [Toc] [Back]
Disk modules are identified within Array Manager 60 using a numbered
pair of the form n:n. The first number identifies the SCSI channel
(or bus) connecting the array controller to the enclosure containing
the disk module. The channel number is indicated on the back of the
array controller enclosure. The second number is the disk module SCSI
ID. The SCSI ID is determined by the slot in which the disk module is
installed, but is not the same as the physical slot number (0-9).
For example, the numbered pair 2:1 identifies the disk module on
channel 2 with a SCSI ID of 1. Refer to the Disk Array FC/60 User's
Guide for more information on disk module addressing.
Options [Toc] [Back]
amcfg supports the following options:
-c capacity Indicates the capacity of the LUN being created.
The capacity can be specified in megabytes (M), or
gigabytes (G) by appending the appropriate letter
to the value. If not specified, the default is
gigabytes.
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
By default, the LUN will use the entire capacity
available from all the disks. It is possible to
specify a lower value for LUN capacity, but this
will result in unused disk capacity. Any capacity
not included in the LUN will be inaccessible and
is essentially wasted capacity.
-C Calculate the capacity of a LUN using the
specified disks, RAID level, and stripe segment
size. This command does not actually create the
LUN. It simply returns the capacity available if
a LUN is created using the specified values.
-d channel:ID,channel:ID
Identifies the disks used for the LUN. Multiple
disks can be specified. Each disk is identified
by channel number (1-6) and SCSI ID (0-4, 8-12).
Note that multiple disks must be specified with no
spaces between each disk.
To ensure high-availability, each disk should be
in a differenet disk enclosure. This protects the
LUN against an enclosure failure.
NOTE: When selecting disks for a RAID 0/1 LUN, the
order in which you specify disks is important.
The first half of the disks you specify will be
the primary data disks, and the second half of the
disks will be the disk mirrors. To maintain data
availability, the disk mirrors must be in a
different enclosure than the data disks.
For example, assume you are creating a 4-disk RAID
0/1 LUN using one disk enclosure on channel 1, and
a second disk enclosure on channel 2. Specifying
the disks in the order 1:2, 1:3, 2:2, 2:3 would
result in mirrored pairs of 1:2/2:2 and 1:3/2:3.
This would ensure availability because the data
disks are on channel 1, and the mirror disks are
on channel 2. However, specifying disks in the
order 1:2, 2:2, 1:3, and 2:3 would result in
mirrored pairs of 1:2/1:3 and 2:2/2:3. This would
put the data disk and mirror disk of each pair in
the same enclosure, making the LUN vulnerable to
an enclosure failure.
-D LUN Delete the LUN identified by LUN.
-force Allows a LUN to be created using two or more disks
in the same enclosure. This option allows you to
override the high-availability protection designed
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
into the LUN binding process. Using this option
you can specify more than one disk per enclosure.
You can also use this option to create a RAID 5
LUN that includes more than six disks.
-L cntrlrID:LUN
Create a LUN with the number specified by LUN.
The LUN will be owned by the controller identified
by cntrlrID.
-M LUN -c cntrlrID
Change the ownership of the LUN specified by LUN
to the controller specified by cntrlrID.
-r RAIDlevel Identifies the RAID level used for the LUN. RAID
levels that can be specified are 0, 1, and 5. A
RAID 0/1 LUN is created by selecting RAID 1 with
more than two disks. RAID 0 is available only on
firmware HP07 and later.
CAUTION: RAID 0 does not provide data redundancy.
It should only be used in situations where high
performance is more important than data
protection. The failure of any disk within a RAID
0 LUN will cause the loss of all data on the LUN.
RAID 0 should only be used for non-critical data
that could be lost in the event of a hardware
failure.
-R cntrlrID:LUN
Replace (unbind and rebind) the LUN with the
number specified by LUN on the controller
identified by cntrlrID.
-s SegmentSize Identifies the stripe segment size used for the
LUN. The stripe segment size is specified in
Kbytes and must be a multiple of the current cache
page size setting. For example, if the cache page
size is set to 4 Kbytes, valid settings would be
4, 8, 16, 64, etc.
-V Verbose mode displays additional command
execution, state, and/or status messages.
-? Display expanded usage message. This option
overrides all others.
SECURITY CONFIGURATION [Toc] [Back]
This command is modified for all security configurations.
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
Security Behavior/Restrictions
Use of this command is restricted to authorized users only.
Command Authorizations [Toc] [Back]
This command requires the sysadmin authorization to successfully
execute.
Privileges [Toc] [Back]
The command has been modified to support least privilege. The
potential privileges possessed by the command and their uses include:
allowdacread This privilege is raised to provide discretionary
read access to the devices.
allowdacwrite This privilege is raised to provide discretionary
write access to the devices.
allowmacread This privilege is raised to provide mandatory read
access to the devices.
allowmacwrite This privilege is raised to provide mandatory
write access to the devices.
filesysops This privilege is raised to allow the mknod(2)
system call to succeed.
writeaudit The command generates its own audit records and
submits these directly to the system audit trail.
This privilege is raised whenever the command
needs to write an audit record.
EXTERNAL INFLUENCES [Toc] [Back]
Environment Variables
LC_MESSAGES determines the language in which messages are displayed.
The current language settings can be checked with locale(1).
RETURN VALUE [Toc] [Back]
amcfg returns the following values:
0 Successful completion.
1 An error in execution (I/O, subsystem, security, etc.)
occurred.
2 An error in command syntax occurred: for example, an unknown
command-line option was passed.
3 Timeout in communication to server. May indicate AM60Srvr
is not running.
DIAGNOSTICS [Toc] [Back]
The following messages can be generated by amcfg:
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
Usage:amcfg { -L | -R } <CntrlrID>:<LUN>
-d <Channel:Id>[,<Channel:Id>...] -r <RAIDLevel>
[-c <Capacity>] [-s <SegmentSize>] [-force]
[-V] [-S] <ArrayID>
amcfg -C -d <Channel:Id>[,<Channel:Id>...]
-r <RAIDLevel> [-s <SegmentSize>]
[-V] [-S] <ArrayID>
amcfg -D <LUN> [-V] [-S] <ArrayID>
amcfg -M <LUN> -c <CntrlrID>
[-V] [-S] <ArrayID>
Extended help: amcfg -?
An error in command syntax has occurred. Re-enter the command
with all necessary arguments.
amcfg: The <ArrayID> entered does not identify a known, supported
array
The specified ArrayID does not exist or does not identify a
device that is communicating with the system. Verify the array
exists and is operational.
amcfg: The specified controller is not physically installed.
A controller-specific command was issued to a non-existent or
inaccessible controller.
amcfg: The specified LUN does not exist in this array.
The specified LUN does not exist.
amcfg: The capacity specified exceeds total available for disks.
LUN not created.
The capacity requested exceeds available capacity for the disks
requested.
amcfg: Unknown capacity subscript: x
A capacity subscript of M or G was expected, or none at all.
Found x instead. Re-enter command with correct subscript.
amcfg: Capacity must be >= 10 MB
An attempt was made to create a LUN with a capacity less than 10
MB. A minimum size of 10 MB is required. Re-issue the command
with a larger capacity specification.
amcfg: LUN already owned by specified controller
An attempt was made to change the ownership of a LUN to the same
controller that already owns it. No operation is performed.
amcfg: LUN 0 may not be deleted. Use -R option to replace LUN 0
instead.
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
An attempt was made to delete LUN 0, which is not allowed. LUN 0
may, however, be reconfigured using amcfg -R. No operation is
performed.
amcfg: LUN's owning controller not responding.
Check controller status or bind LUN to the other controller.
An attempt was made to bind a LUN to a controller which is not
responding. No operation is performed.
amcfg: LUN's new owning controller not responding.
Check controller status or bind LUN to the other controller.
An attempt was made to replace (unbind and rebind) a LUN, but the
new owning controller does not respond. No operation is
performed.
amcfg: The specified operation cannot be performed
on a passive controller.
An attempt was made to bind or replace a LUN on a passive
controller.
amcfg: Error in command execution, <Additional Error Info>:
<Error Info Decode>
The command failed due to a device error, an internal error, or a
system error. The Additional Error Info and Error Info Decode
fields will hold specifics about the failure and its cause.
amcfg: A RAID 5 LUN with more than one disk on a channel is not a
recommended high availability configuration. Use -force to
override.
amcfg: A RAID 5 LUN with more than one disk in an enclosure is not
a recommended high availability configuration. Use -force to
override.
amcfg: A RAID 5 LUN with more than six disks in this array is not
a recommended high availability configuration. Use -force to
override.
amcfg: A RAID 0/1 LUN with both mirrors residing on the same channel
is not a recommended high availability configuration. Use -force
to override.
amcfg: A RAID 0/1 LUN with both mirrors residing in the same enclosure
is not a recommended high availability configuration. Use -force
to override.
amcfg: A RAID 0/1 LUN may contain no more than 30 disks.
The absolute maximum number of disks that the array will support
in a RAID 0/1 LUN has been exceeded.
Hewlett-Packard Company - 6 - HP-UX 11i Version 2: August 2003
amcfg(1M) amcfg(1M)
amcfg: A RAID 5 LUN may contain no more than 20 disks.
The absolute maximum number of disks that the array will support
in a RAID 5 LUN has been exceeded.
EXAMPLES [Toc] [Back]
Bind a 5-disk, RAID 5 LUN on disk array RACK_51. The disk array
includes five disk enclosures, each on its own channel. The capacity
of the LUN will default to the total capacity available from the five
disks. The LUN is owned by controller A, is assigned number 2, and
uses a stripe segment size of 16 Kbytes. Note that each disk is in a
different enclosure for high availability, and that there are no
spaces between the individual disk parameters.
amcfg -L A:2 -d 1:1,2:2,3:1,4:4,5:3 -r 5 -s 16 RACK_51
Bind a RAID 0/1 LUN on disk array RACK_51. The LUN is owned by
controller B, is assigned number 4, and uses a stripe segment size of
4 Kbytes. Note that the disks selected create mirrored pairs that are
in separate enclosures (1:3, 2:3 and 1:4, 2:4). This maintains high
availability. Although RAID 1 is specified, the inclusion of more
than two disks causes the disk array to create a RAID 0/1 LUN.
amcfg -L B:4 -d 1:3,1:4,2:3,2:4 -r 1 -s 4 RACK_51
Calculate the available capacity from a five-disk RAID 5 LUN on disk
array RACK_51.
amcfg -C -d 1:2,2:2,3:2,4:6 -r 5 -s 32 RACK_51
Delete LUN 3 on the disk array RACK_51:
amcfg -D 3 RACK_51
Change the ownership of LUN 0 on disk array RACK_51 to controller B:
amcfg -M 0 -c B RACK_51
DEPENDENCIES [Toc] [Back]
AM60Srvr must be running to execute this command. See AM60Srvr(1M).
AUTHOR [Toc] [Back]
amcfg was developed by HP.
SEE ALSO [Toc] [Back]
amdsp(1M), ammgr(1M), amutil(1M), amlog(1M), AM60Srvr(1M).
Hewlett-Packard Company - 7 - HP-UX 11i Version 2: August 2003 [ Back ] |